aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-10-31 03:22:20 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-10-31 03:22:20 +0000
commit1009be28b6503286851d6e544c4df32c7f4dd624 (patch)
treeacbdaee4fe4ea48cbdb5cd6539e3961c7f343e47 /www/lighttpd
parentd62e2f839b7e0a03b60a7c3a5e27dee9915fe4ac (diff)
downloadports-1009be28b6503286851d6e544c4df32c7f4dd624.tar.gz
ports-1009be28b6503286851d6e544c4df32c7f4dd624.zip
Notes
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile66
-rw-r--r--www/lighttpd/distinfo6
-rw-r--r--www/lighttpd/files/patch-src__mod_webdav.c18
3 files changed, 70 insertions, 20 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 8f37102a4632..0f5d28d9e379 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lighttpd
-PORTVERSION= 1.4.12
+PORTVERSION= 1.4.13
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://mirrors.cat.pdx.edu/lighttpd/
@@ -29,11 +29,16 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= lighttpd.1 spawn-fcgi.1
-OPTIONS= OPENSSL "Enable SSL support" on \
- OPENLDAP "Enable LDAP support" off \
- MYSQL "Enable MYSQL support" off \
- IPV6 "Enable IPV6 support" on \
- CML "Enable Cache Meta Language support" off
+OPTIONS= BZIP2 "Enable Bzip2 support" off \
+ CML "Enable Cache Meta Language support" off \
+ FAM "Enable fam/gamin support" off \
+ GDBM "Enable gdbm storage support" off \
+ IPV6 "Enable IPV6 support" on \
+ MEMCACHE "Enable memcached storage support" off \
+ MYSQL "Enable MYSQL support" off \
+ OPENLDAP "Enable LDAP support" off \
+ OPENSSL "Enable SSL support" on \
+ VALGRIND "Enable valgrind support" off
.include <bsd.port.pre.mk>
@@ -47,10 +52,34 @@ CONFIGURE_ARGS+= --with-openssl \
--with-openssl-libs=${OPENSSLLIB}
.endif
-.if defined(WITH_OPENLDAP)
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+= --with-ldap
-_REQUIRE+= slapd
+.if defined(WITH_BZIP2)
+LIB_DEPENDS+= bz2:${PORTSDIR}/archivers/bzip2
+CONFIGURE_ARGS+= --with-bzip2
+.endif
+
+.if defined(WITH_CML)
+USE_LUA= yes
+CONFIGURE_ARGS+= --with-lua
+CONFIGURE_ENV+= LUA_CFLAGS="-I${LUA_INCDIR}" LUA_LIBS="-L${LUA_LIBDIR}"
+.endif
+
+.if defined(WITH_FAM)
+LIB_DEPENDS+= fam:${PORTSDIR}/devel/fam
+CONFIGURE_ARGS+= --with-fam
+CONFIGURE_ENV+= FAM_CFLAGS="-I${LOCALBASE}/include" FAM_LIBS="-L${LOCALBASE}/lib"
+.endif
+
+.if defined(WITH_GDBM)
+LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+CONFIGURE_ARGS+= --with-gdbm
+.endif
+
+.if defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
+.if defined(WITH_MEMCACHE)
+CONFIGURE_ARGS+= --with-memcache
.endif
.if defined(WITH_MYSQL)
@@ -59,20 +88,23 @@ CONFIGURE_ARGS+= --with-mysql
_REQUIRE+= mysql
.endif
-.if defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+= --disable-ipv6
+.if defined(WITH_OPENLDAP)
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+= --with-ldap
+_REQUIRE+= slapd
.endif
-.if defined(WITH_CML)
-USE_LUA= 5.0
-CONFIGURE_ARGS+= --with-lua
-CONFIGURE_ENV+= CPPFLAGS="-I${LUA_INCDIR}" LDFLAGS="-L${LUA_LIBDIR}"
+.if defined(WITH_VALGRIND)
+BUILD_DEPENDS+= valgrind:${PORTSDIR}/devel/valgrind
+RUN_DEPENDS+= valgrind:${PORTSDIR}/devel/valgrind
+CONFIGURE_ARGS+= --with-valgrind
.endif
SUB_LIST+= REQUIRE="${_REQUIRE}"
post-patch:
- @${REINPLACE_CMD} -E -e 's|-D_XOPEN_SOURCE=600||' ${WRKSRC}/configure.in
+ @${REINPLACE_CMD} -e 's|-D_XOPEN_SOURCE=600||' -e 's|-std=gnu99||' \
+ ${WRKSRC}/configure.in
post-install:
@${INSTALL_DATA} ${FILESDIR}/lighttpd.conf.sample ${PREFIX}/etc
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index beeca9333ec7..907f7a388240 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (lighttpd-1.4.12.tar.gz) = 8f6756452138f5da384251f849b329f2
-SHA256 (lighttpd-1.4.12.tar.gz) = 9f69b7fcf3868a9f27c687a4f091a2e7ac703238130b5bbec34e6630fa70b07a
-SIZE (lighttpd-1.4.12.tar.gz) = 796002
+MD5 (lighttpd-1.4.13.tar.gz) = d775d6478391b95d841a1018c8db0b95
+SHA256 (lighttpd-1.4.13.tar.gz) = 62d5997fdb41afa9400adcdb040d04a1f5fa950045df96e3e3f593e8f0de5739
+SIZE (lighttpd-1.4.13.tar.gz) = 797813
diff --git a/www/lighttpd/files/patch-src__mod_webdav.c b/www/lighttpd/files/patch-src__mod_webdav.c
new file mode 100644
index 000000000000..e8176d65b38e
--- /dev/null
+++ b/www/lighttpd/files/patch-src__mod_webdav.c
@@ -0,0 +1,18 @@
+--- src/mod_webdav.c.orig Tue Oct 10 01:08:09 2006
++++ src/mod_webdav.c Tue Oct 10 01:09:02 2006
+@@ -1151,11 +1151,13 @@
+ *
+ */
+ int webdav_has_lock(server *srv, connection *con, plugin_data *p, buffer *uri) {
+- UNUSED(srv);
+ int has_lock = 1;
+-
+ #ifdef USE_LOCKS
+ data_string *ds;
++#endif
++ UNUSED(srv);
++
++#ifdef USE_LOCKS
+
+ /**
+ * This implementation is more fake than real