aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2009-02-24 14:32:40 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2009-02-24 14:32:40 +0000
commitb632d249a4831d103d7b8c1098efe03dfed18d18 (patch)
treeaa8ad36aeee01c809bba26ad72a42dfbc854ff4b /www/lighttpd
parent2254aade9eb9ad583eeb71b50d484984efe6020e (diff)
Notes
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile1
-rw-r--r--www/lighttpd/files/patch-src__network_freebsd_sendfile.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 0598c871906b..7c5260380ea0 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lighttpd
PORTVERSION= 1.4.21
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://mirrors.cat.pdx.edu/lighttpd/
diff --git a/www/lighttpd/files/patch-src__network_freebsd_sendfile.c b/www/lighttpd/files/patch-src__network_freebsd_sendfile.c
new file mode 100644
index 000000000000..f823657de4c1
--- /dev/null
+++ b/www/lighttpd/files/patch-src__network_freebsd_sendfile.c
@@ -0,0 +1,14 @@
+#
+# Backport http://redmine.lighttpd.net/projects/lighttpd/repository/revisions/2403
+#
+--- src/network_freebsd_sendfile.c.orig 2009-02-24 11:05:06.000000000 -0300
++++ src/network_freebsd_sendfile.c 2009-02-24 11:12:15.000000000 -0300
+@@ -167,7 +167,7 @@
+ switch(errno) {
+ case EAGAIN:
+ case EINTR:
+- r = 0; /* try again later */
++ /* for EAGAIN and EINTR r still contains the sent bytes */
+ break;
+ case ENOTCONN:
+ return -2;