aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-02-22 18:42:58 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-02-22 18:42:58 +0000
commit5bd25f6cfe73fad8c35c6efec1a88f82c484610c (patch)
treebe868e7c304039a49266e761ccf0a94a65e56b23 /www/lighttpd
parent3b73b5ac4f7f33c912acf0043a199e188794e553 (diff)
downloadports-5bd25f6cfe73fad8c35c6efec1a88f82c484610c.tar.gz
ports-5bd25f6cfe73fad8c35c6efec1a88f82c484610c.zip
Notes
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile4
-rw-r--r--www/lighttpd/distinfo4
-rw-r--r--www/lighttpd/files/patch-src::Makefile.in27
-rw-r--r--www/lighttpd/files/patch-src::mod_cgi.c (renamed from www/lighttpd/files/patch-src::cgi.c)12
4 files changed, 7 insertions, 40 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 56646bd5e2c9..f4d8c2493cd9 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lighttpd
-PORTVERSION= 1.3.10
-PORTREVISION= 1
+PORTVERSION= 1.3.11
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://dl.fkb.wormulon.net/lighttpd/ \
@@ -25,6 +24,7 @@ USE_LIBTOOL_VER= 15
USE_GNOME= lthack
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LIBS=-L${PREFIX}/lib
+CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd
STARTUP_FILE= ${PREFIX}/etc/rc.d/lighttpd.sh
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index a22da7685b86..5c7ca24a466c 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,2 +1,2 @@
-MD5 (lighttpd-1.3.10.tar.gz) = 28623eff50653a9b104ddb20fe65aaf1
-SIZE (lighttpd-1.3.10.tar.gz) = 667324
+MD5 (lighttpd-1.3.11.tar.gz) = 730c9b9d743360d23e523968ab4fe7c5
+SIZE (lighttpd-1.3.11.tar.gz) = 670438
diff --git a/www/lighttpd/files/patch-src::Makefile.in b/www/lighttpd/files/patch-src::Makefile.in
deleted file mode 100644
index d8eb0bb9939a..000000000000
--- a/www/lighttpd/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/Makefile.in.orig Fri Oct 1 03:47:40 2004
-+++ src/Makefile.in Fri Oct 1 17:05:04 2004
-@@ -65,7 +65,7 @@
-
- #hdr += chat.h chat_misc.h chat_endec.h chat_user.h \
- # chat_channel.h
--DEFS = @DEFS@ -DLIBRARY_DIR="\"$(libdir)\""
-+DEFS = @DEFS@ -DLIBRARY_DIR="\"$(libdir)/lighttpd\""
- DEPDIR = @DEPDIR@
- DL_LIB = @DL_LIB@
- ECHO = @ECHO@
-@@ -599,12 +599,12 @@
- libLTLIBRARIES_INSTALL = $(INSTALL)
- install-libLTLIBRARIES: $(lib_LTLIBRARIES)
- @$(NORMAL_INSTALL)
-- $(mkinstalldirs) $(DESTDIR)$(libdir)
-+ $(mkinstalldirs) $(DESTDIR)$(libdir)/lighttpd
- @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
- if test -f $$p; then \
- f="`echo $$p | sed -e 's|^.*/||'`"; \
-- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(libdir)/$$f"; \
-- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(libdir)/$$f; \
-+ echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(libdir)/lighttpd/$$f"; \
-+ $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(libdir)/lighttpd/$$f; \
- else :; fi; \
- done
-
diff --git a/www/lighttpd/files/patch-src::cgi.c b/www/lighttpd/files/patch-src::mod_cgi.c
index 2c8e7d73e61e..e8c6fc589182 100644
--- a/www/lighttpd/files/patch-src::cgi.c
+++ b/www/lighttpd/files/patch-src::mod_cgi.c
@@ -1,14 +1,8 @@
---- ./src/cgi.c~ 2005-02-08 00:08:01.000000000 +0200
-+++ ./src/cgi.c 2005-02-08 00:13:02.000000000 +0200
-@@ -686,16 +686,18 @@
+--- src/mod_cgi.c (revision 34)
++++ src/mod_cgi.c (revision 35)
+@@ -690,12 +690,14 @@
- int to_cgi_fds[2];
- int from_cgi_fds[2];
-- struct stat st;
--
-+
#ifndef __WIN32
-+ struct stat st;
- /* stat the exec file */
- if (-1 == (stat(cgi_handler->ptr, &st))) {