aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-06-03 17:57:42 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-06-03 17:57:42 +0000
commit512694953a7e0e9b4e2e037a3758fc131eb62d04 (patch)
treeffd626eec8f6534d53966273e0313771f02aed37 /www/lighttpd
parenta2849b70c4f5540fd145f12fbdd7ef7f11ef32ba (diff)
downloadports-512694953a7e0e9b4e2e037a3758fc131eb62d04.tar.gz
ports-512694953a7e0e9b4e2e037a3758fc131eb62d04.zip
Notes
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile35
-rw-r--r--www/lighttpd/distinfo2
-rw-r--r--www/lighttpd/files/lighttpd.conf.sample161
-rw-r--r--www/lighttpd/files/lighttpd.sh.tmpl41
-rw-r--r--www/lighttpd/files/patch-src::Makefile.in27
-rw-r--r--www/lighttpd/pkg-descr8
-rw-r--r--www/lighttpd/pkg-plist20
7 files changed, 294 insertions, 0 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
new file mode 100644
index 000000000000..e58b3e3e49e0
--- /dev/null
+++ b/www/lighttpd/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lighttpd
+# Date created: 20 May 2004
+# Whom: k@123.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= lighttpd
+PORTVERSION= 1.2.1
+CATEGORIES= www
+MASTER_SITES= http://jan.kneschke.de/projects/lighttpd/download/
+
+MAINTAINER= k@123.org
+COMMENT= A secure, fast, compliant, and very flexible Web Server
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+USE_REINPLACE= yes
+USE_RC_SUBR= yes
+USE_LIBTOOL= yes
+USE_GNOME= lthack
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LIBS=-L${PREFIX}/lib
+STARTUP_FILE= ${PREFIX}/etc/rc.d/lighttpd.sh
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+
+MAN1= lighttpd.1
+
+post-install:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/lighttpd.sh.tmpl > ${STARTUP_FILE}
+ @${CHMOD} 755 ${STARTUP_FILE}
+ @${INSTALL_DATA} ${FILESDIR}/lighttpd.conf.sample ${PREFIX}/etc/
+
+.include <bsd.port.mk>
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
new file mode 100644
index 000000000000..0a7e27ba0621
--- /dev/null
+++ b/www/lighttpd/distinfo
@@ -0,0 +1,2 @@
+MD5 (lighttpd-1.2.1.tar.gz) = 0ff694a06a5fb7ed8964e01b5033b35b
+SIZE (lighttpd-1.2.1.tar.gz) = 554487
diff --git a/www/lighttpd/files/lighttpd.conf.sample b/www/lighttpd/files/lighttpd.conf.sample
new file mode 100644
index 000000000000..f57893d0e3fd
--- /dev/null
+++ b/www/lighttpd/files/lighttpd.conf.sample
@@ -0,0 +1,161 @@
+# lighttpd configuration file
+#
+# use a it as base for lighttpd 1.0.0 and above
+#
+# $Id: lighttpd.conf,v 1.3 2004/02/07 21:15:05 weigon Exp $
+
+############ Options you really have to take care of ####################
+
+## modules to load
+# at least mod_access and mod_accesslog should be loaded
+# all other module should only be loaded if really neccesary
+# - saves some time
+# - saves memory
+server.modules = (
+# "mod_rewrite",
+ "mod_access",
+# "mod_auth",
+# "mod_status",
+# "mod_fastcgi",
+# "mod_simple_vhost",
+# "mod_evhost",
+# "mod_cgi",
+# "mod_compress",
+ "mod_accesslog" )
+
+## a static document-root, for virtual-hosting take look at the
+## server.virtual-* options
+server.document-root = "/var/www/"
+
+## where to send error-messages to
+server.errorlog = "/var/log/lighttpd/error.log"
+
+# files to check for if .../ is requested
+server.indexfiles = ( "index.php", "index.html",
+ "index.htm", "default.htm" )
+
+# mimetype mapping
+mimetype.assign = ( ".png" => "image/png",
+ ".jpg" => "image/jpeg",
+ ".jpeg" => "image/jpeg",
+ ".gif" => "image/gif",
+ ".html" => "text/html",
+ ".htm" => "text/html",
+ ".pdf" => "application/pdf",
+ ".swf" => "application/x-shockwave-flash",
+ ".spl" => "application/futuresplash",
+ ".txt" => "text/plain",
+ ".tar.gz" => "application/x-tgz",
+ ".tgz" => "application/x-tgz",
+ ".gz" => "application/x-gzip",
+ ".c" => "text/plain",
+ ".conf" => "text/plain" )
+
+#### accesslog module
+accesslog.filename = "/var/log/lighttpd/access.log"
+
+## deny access the file-extensions
+#
+# ~ is for backupfiles from vi, emacs, joe, ...
+# .inc is often used for code includes which should in general not be part
+# of the document-root
+url.access-deny = ( "~", ".inc" )
+
+
+
+######### Options that are good to be but not neccesary to be changed #######
+
+## bind to port (default: 80)
+#server.port = 81
+
+## bind to localhost (default: all interfaces)
+#server.bind = "grisu.home.kneschke.de"
+
+
+###### virtual hosts
+##
+## If you want name-based virtual hosting add the next three settings and load
+## mod_simple_vhost
+##
+## document-root =
+## virtual-server-root + virtual-server-default-host + virtual-server-docroot or
+## virtual-server-root + http-host + virtual-server-docroot
+##
+#simple-vhost.server-root = "/home/weigon/wwwroot/servers/"
+#simple-vhost.default-host = "grisu.home.kneschke.de"
+#simple-vhost.document-root = "/pages/"
+
+
+##
+## Format: <errorfile-prefix><status>.html
+## -> ..../status-404.html for 'File not found'
+#server.errorfile-prefix = "/home/weigon/projects/lighttpd/doc/status-"
+
+## virtual directory listings
+#server.dir-listing = "enable"
+
+## send unhandled HTTP-header headers to error-log
+#debug.dump-unknown-headers = "enable"
+
+### only root can use these options
+#
+# chroot() to directory (default: no chroot() )
+#server.chroot = "/"
+
+## change uid to <uid> (default: don't care)
+server.username = "www-data"
+
+## change uid to <uid> (default: don't care)
+server.groupname = "www-data"
+
+server.pid-file = "/var/run/lighttpd.pid"
+#### compress module
+#compress.cache-dir = "/var/tmp/lighttpd/cache/compress/"
+#compress.filetype = ("text/plain", "text/html")
+
+#### fastcgi module
+#fastcgi.server = ( ".php" =>
+# ( "grisu" =>
+# (
+# "host" => "192.168.2.10",
+# "port" => 1026
+# )
+# )
+# )
+
+#### CGI module
+#cgi.assign = ( ".pl" => "/usr/bin/perl",
+# ".cgi" => "/usr/bin/perl" )
+#
+
+#### SSL engine
+#ssl.engine = "enable"
+#ssl.pemfile = "server.pem"
+
+#### status module
+#status.rrd-reports = "enable"
+#status.rrd-dir = "/home/weigon/wwwroot/logs/"
+
+#### auth module
+#auth.backend = "plain"
+#auth.backend.plain.userfile = "lighttpd.user"
+#auth.backend.plain.groupfile = "lighttpd.group"
+
+#auth.require = ( "/server-status" =>
+# (
+# "method" => "digest",
+# "realm" => "download archiv",
+# "require" => "group=www|user=jan|host=192.168.2.10"
+# ),
+# "/server-info" =>
+# (
+# "method" => "digest",
+# "realm" => "download archiv",
+# "require" => "group=www|user=jan|host=192.168.2.10"
+# )
+# )
+
+#### url handling modules (rewrite, redirect, access)
+#url.rewrite = ( "^/$" => "/server-status" )
+#url.redirect = ( "^/wishlist/(.+)" => "http://www.123.org/$1" )
+
diff --git a/www/lighttpd/files/lighttpd.sh.tmpl b/www/lighttpd/files/lighttpd.sh.tmpl
new file mode 100644
index 000000000000..6fe7a01d66f7
--- /dev/null
+++ b/www/lighttpd/files/lighttpd.sh.tmpl
@@ -0,0 +1,41 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: lighttpd
+# REQUIRE: DAEMON
+# BEFORE: LOGIN
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable lighttpd:
+#
+#lighttpd_enable="YES"
+#
+# See lighttpd(1) for manual
+#
+
+. %%RC_SUBR%%
+
+name=lighttpd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/lighttpd
+pidfile=/var/run/lighttpd.pid
+required_files=%%PREFIX%%/etc/lighttpd.conf
+
+stop_postcmd=stop_postcmd
+
+stop_postcmd()
+{
+ rm -f $pidfile
+}
+
+# set defaults
+
+lighttpd_enable=${lighttpd_enable:-"NO"}
+lighttpd_flags=${lighttpd_flags:-""}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/www/lighttpd/files/patch-src::Makefile.in b/www/lighttpd/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..9d7610fdda9c
--- /dev/null
+++ b/www/lighttpd/files/patch-src::Makefile.in
@@ -0,0 +1,27 @@
+--- src/Makefile.in.orig Tue Mar 23 18:30:12 2004
++++ src/Makefile.in Wed Mar 24 05:25:13 2004
+@@ -57,7 +57,7 @@
+
+ #hdr += chat.h chat_misc.h chat_endec.h chat_user.h \
+ # chat_channel.h
+-DEFS = @DEFS@ -DLIBRARY_DIR="\"$(libdir)\""
++DEFS = @DEFS@ -DLIBRARY_DIR="\"$(libdir)/lighttpd\""
+ DEPDIR = @DEPDIR@
+ DL_LIB = @DL_LIB@
+ ECHO = @ECHO@
+@@ -373,12 +373,12 @@
+ libLTLIBRARIES_INSTALL = $(INSTALL)
+ install-libLTLIBRARIES: $(lib_LTLIBRARIES)
+ @$(NORMAL_INSTALL)
+- $(mkinstalldirs) $(DESTDIR)$(libdir)
++ $(mkinstalldirs) $(DESTDIR)$(libdir)/lighttpd
+ @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(libdir)/$$f"; \
+- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(libdir)/$$f; \
++ echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(libdir)/lighttpd/$$f"; \
++ $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(libdir)/lighttpd/$$f; \
+ else :; fi; \
+ done
+
diff --git a/www/lighttpd/pkg-descr b/www/lighttpd/pkg-descr
new file mode 100644
index 000000000000..05afa3fc5c8e
--- /dev/null
+++ b/www/lighttpd/pkg-descr
@@ -0,0 +1,8 @@
+lighttpd a secure, fast, compliant and very flexible web-server which
+has been optimized for high-performance environments. It has a very
+low memory footprint compared to other webservers and takes care of
+cpu-load. Its advanced feature-set (FastCGI, CGI, Auth, Output-Compression,
+URL-Rewriting and many more) make lighttpd the perfect webserver-software
+for every server that is suffering load problems.
+
+WWW: http://jan.kneschke.de/projects/lighttpd/
diff --git a/www/lighttpd/pkg-plist b/www/lighttpd/pkg-plist
new file mode 100644
index 000000000000..7491adad2396
--- /dev/null
+++ b/www/lighttpd/pkg-plist
@@ -0,0 +1,20 @@
+etc/lighttpd.conf.sample
+etc/rc.d/lighttpd.sh
+lib/lighttpd/mod_access.so
+lib/lighttpd/mod_accesslog.so
+lib/lighttpd/mod_auth.so
+lib/lighttpd/mod_cgi.so
+lib/lighttpd/mod_compress.so
+lib/lighttpd/mod_evhost.so
+lib/lighttpd/mod_expire.so
+lib/lighttpd/mod_fastcgi.so
+lib/lighttpd/mod_httptls.so
+lib/lighttpd/mod_maps.so
+lib/lighttpd/mod_redirect.so
+lib/lighttpd/mod_rewrite.so
+lib/lighttpd/mod_secdownload.so
+lib/lighttpd/mod_simple_vhost.so
+lib/lighttpd/mod_status.so
+lib/lighttpd/mod_usertrack.so
+sbin/lighttpd
+@dirrm lib/lighttpd