aboutsummaryrefslogtreecommitdiff
path: root/www/lilurl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-09-14 07:18:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-09-14 07:18:14 +0000
commit56246a50be284e10052276f054e657d5e7b12ae8 (patch)
tree5b29e2c56e18f84f60dd88c8df8c3126a1f422c5 /www/lilurl
parentfc504b4fb0134e6fd3b72bc5c20548fdcca68bbf (diff)
downloadports-56246a50be284e10052276f054e657d5e7b12ae8.tar.gz
ports-56246a50be284e10052276f054e657d5e7b12ae8.zip
Notes
Diffstat (limited to 'www/lilurl')
-rw-r--r--www/lilurl/Makefile48
-rw-r--r--www/lilurl/distinfo3
-rw-r--r--www/lilurl/files/pkg-message.in21
-rw-r--r--www/lilurl/pkg-descr5
4 files changed, 77 insertions, 0 deletions
diff --git a/www/lilurl/Makefile b/www/lilurl/Makefile
new file mode 100644
index 000000000000..b5f37b4e7ae5
--- /dev/null
+++ b/www/lilurl/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: lilurl
+# Date created: 2006/09/10
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lilurl
+PORTVERSION= 0.1.1
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= A simple PHP/MySQL script for generating lil? URLs
+
+USE_PHP= mysql pcre
+NO_BUILD= yes
+WANT_PHP_WEB= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+LILURL_DIR?= www/lilurl
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+PLIST= ${WRKDIR}/pkg-plist
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ @${MV} ${WRKSRC}/includes/conf.php ${WRKSRC}/includes/conf.php.sample
+
+pre-install:
+ @cd ${WRKSRC} && ${FIND} -s . -type f | \
+ ${SED} -e 's|^./||;s|^|${LILURL_DIR}/|' > ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's|^|@dirrm ${LILURL_DIR}/|' >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${LILURL_DIR} >> ${PLIST}
+
+do-install:
+ ${MKDIR} ${TARGETDIR}/${LILURL_DIR}
+ @${CP} -R ${WRKSRC}/ ${TARGETDIR}/${LILURL_DIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${TARGETDIR}/${LILURL_DIR}
+
+post-install:
+ @${SED} -e 's,%%TARGETDIR%%,${TARGETDIR},; s,%%LILURL_DIR%%,${LILURL_DIR},g' \
+ ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/lilurl/distinfo b/www/lilurl/distinfo
new file mode 100644
index 000000000000..c633594ffb52
--- /dev/null
+++ b/www/lilurl/distinfo
@@ -0,0 +1,3 @@
+MD5 (lilurl-0.1.1.tar.gz) = 35a48bb6c3a53ead7a25cf373a8e631d
+SHA256 (lilurl-0.1.1.tar.gz) = 819f2d82b8106141bfa5cc9f15870eb7f3ed21a2e2b46fadd28e1ceb2181055f
+SIZE (lilurl-0.1.1.tar.gz) = 3991
diff --git a/www/lilurl/files/pkg-message.in b/www/lilurl/files/pkg-message.in
new file mode 100644
index 000000000000..f55728eb858d
--- /dev/null
+++ b/www/lilurl/files/pkg-message.in
@@ -0,0 +1,21 @@
+=======================================================================
+lilurl is now installed. If you intall it for the first time,
+you may have to follow this steps to make it work correctly:
+
+1. Create the MySQL database:
+# mysqladmin --user=root create lilurl
+
+2. Create a mysql user/password for lilurl:
+(change user and/or password if requered)
+# echo "GRANT ALL ON lilurl.* TO lilurluser@localhost IDENTIFIED BY 'lilurluser'; FLUSH PRIVILEGES;" | mysql
+
+3. Import the default lilurl database:
+# mysql lilurl < %%TARGETDIR%%/%%LILURL_DIR%%/lilurl.sql
+
+4. Copy %%TARGETDIR%%/%%LILURL_DIR%%/includes/conf.php.sample to %%TARGETDIR%%/%%LILURL_DIR%%/includes/conf.php
+ Edit %%TARGETDIR%%/%%LILURL_DIR%%/includes/conf.php
+
+5. Add alias in apache config for the lilurl dir:
+Alias /lilurl "%%TARGETDIR%%/%%LILURL_DIR%%/"
+
+=======================================================================
diff --git a/www/lilurl/pkg-descr b/www/lilurl/pkg-descr
new file mode 100644
index 000000000000..538bbc2d82e0
--- /dev/null
+++ b/www/lilurl/pkg-descr
@@ -0,0 +1,5 @@
+lilURL is a simple PHP/MySQL script for generating lil? URLs. It's similar
+to TinyURL, Shorl, MakeAShorterLink, etc, but you can run it on your own
+server. Requires PHP and MySQL. Supports mod_rewrite.
+
+WWW: http://lilurl.sourceforge.net