aboutsummaryrefslogtreecommitdiff
path: root/www/linklint
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-19 10:45:15 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-19 10:45:15 +0000
commitb889f74e3e2a2a26054664c9fe93c74741536b28 (patch)
tree13fca0add312e569eeed4de5aaaae154a54f5585 /www/linklint
parent7c2a5c31da63e049616d479457b7fb573b0bc401 (diff)
downloadports-b889f74e3e2a2a26054664c9fe93c74741536b28.tar.gz
ports-b889f74e3e2a2a26054664c9fe93c74741536b28.zip
Notes
Diffstat (limited to 'www/linklint')
-rw-r--r--www/linklint/Makefile42
-rw-r--r--www/linklint/distinfo2
-rw-r--r--www/linklint/pkg-descr16
3 files changed, 60 insertions, 0 deletions
diff --git a/www/linklint/Makefile b/www/linklint/Makefile
new file mode 100644
index 000000000000..2e1e89c93fdc
--- /dev/null
+++ b/www/linklint/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: linklint
+# Date created: 16 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linklint
+PORTVERSION= 2.3.5
+CATEGORIES= www
+MASTER_SITES= http://www.linklint.org/download/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Perl script that checks links on web sites
+
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/linklint
+HTMLDOC= bugs.html doc_index.html dot.gif hints.html howitworks.html \
+ index.html inputs.html language.html license.html linklint.gif \
+ new.html outputs.html
+DOC= CHANGES.txt
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|.*|#!${PERL}|' \
+ ${WRKSRC}/${DISTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/${DOC} ${DOCSDIR}
+.for f in ${HTMLDOC}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}/html
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/linklint/distinfo b/www/linklint/distinfo
new file mode 100644
index 000000000000..62b5c4cfeb7a
--- /dev/null
+++ b/www/linklint/distinfo
@@ -0,0 +1,2 @@
+MD5 (linklint-2.3.5.tar.gz) = c1ae0860199da59ded28771d1fa7b800
+SIZE (linklint-2.3.5.tar.gz) = 113256
diff --git a/www/linklint/pkg-descr b/www/linklint/pkg-descr
new file mode 100644
index 000000000000..018aa5879340
--- /dev/null
+++ b/www/linklint/pkg-descr
@@ -0,0 +1,16 @@
+Linklint is a perl script that checks links on web sites.
+
+Features:
+
+ * both local-file and HTTP site checking
+ * cross referenced and fully hyperlinked output reports
+ * the ability to check password protected areas
+ * support for all standard server-side image maps
+ * reports of orphan files, and files with mismatching case
+ * a report of which URLs have changed since last checked
+ * support of proxy servers for remote URL checking
+
+WWW: http://www.linklint.org/
+
+- ehaupt
+ehaupt@critical.ch