aboutsummaryrefslogtreecommitdiff
path: root/www/links-hacked
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-09-24 18:45:03 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-09-24 18:45:03 +0000
commit0e68a3bc85d8f6c7024ce265faccf0a9332357d2 (patch)
treea33a239d5a83dd65fe237ea913a804c71cc141f5 /www/links-hacked
parentd5e301ddb7c1d15baed59bb6e2a9cc5090fb29b7 (diff)
downloadports-0e68a3bc85d8f6c7024ce265faccf0a9332357d2.tar.gz
ports-0e68a3bc85d8f6c7024ce265faccf0a9332357d2.zip
Notes
Diffstat (limited to 'www/links-hacked')
-rw-r--r--www/links-hacked/Makefile105
-rw-r--r--www/links-hacked/distinfo2
-rw-r--r--www/links-hacked/pkg-descr5
3 files changed, 112 insertions, 0 deletions
diff --git a/www/links-hacked/Makefile b/www/links-hacked/Makefile
new file mode 100644
index 000000000000..699c8ea4df9c
--- /dev/null
+++ b/www/links-hacked/Makefile
@@ -0,0 +1,105 @@
+# New ports collection makefile for: links-hacked
+# Date created: 24 September 2011
+# Whom: Peter Vereshagin <peter@vereshagin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= links-hacked
+DISTVERSION= 101110
+CATEGORIES?= www
+MASTER_SITES= http://xray.sai.msu.ru/~karpov/links-hacked/downloads/ http://links-hacked.nm.ru/
+
+MAINTAINER= peter@vereshagin.org
+COMMENT= Hacked version of a Links WWW browser
+
+LIB_DEPENDS+= execinfo:${PORTSDIR}/devel/libexecinfo \
+ gdbm:${PORTSDIR}/databases/gdbm
+
+CONFLICTS= links-[0-9]*
+
+USE_AUTOTOOLS?= autoconf autoheader aclocal automake
+AUTOMAKE_ARGS?= -a -c
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-ssl --without-pmshell --without-atheos \
+ --without-fb --enable-form-saving --enable-javascript
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+
+USE_OPENSSL= yes
+
+OPTIONS= SVGALIB "non-X11 graphics support" off \
+ DIRECTFB "directfb driver support" off \
+ X11 "X11 graphics support" on \
+ FORMSAVE "Enable forms saving" on \
+ JS "Enable Javascript (very basic)" on \
+ FREETYPE "Enable Freetype renderer" on
+
+.include <bsd.port.options.mk>
+
+.ifdef(WITH_SVGALIB) || defined(WITH_X11) || defined(WITH_DIRECTFB)
+LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png \
+ jpeg.11:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff
+CONFIGURE_ARGS+= --enable-graphics
+.else
+CONFIGURE_ARGS+= --disable-graphics --without-libjpeg --without-libtiff
+.endif
+
+.ifdef(WITH_SVGALIB)
+LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+CONFIGURE_ARGS+= --with-svgalib
+.else
+CONFIGURE_ARGS+= --without-svgalib
+.endif
+
+.ifdef(WITH_DIRECTFB)
+LIB_DEPENDS+= directfb-1.4.5:${PORTSDIR}/devel/directfb
+CONFIGURE_ARGS+= --with-directfb
+.else
+CONFIGURE_ARGS+= --without-directfb
+.endif
+
+.if !defined(WITHOUT_X11)
+USE_XORG= x11 xproto
+CONFIGURE_ARGS+= --with-x
+DESKTOP_ENTRIES="Links" \
+ "Lynx-like hacked WWW browser" \
+ "links" \
+ "links -g" \
+ "Application;Network;WebBrowser;" \
+ false
+PLIST_FILES+= share/pixmaps/links.xpm
+.else
+CONFIGURE_ARGS+= --without-x
+.endif
+
+.ifdef(WITH_FREETYPE)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+CONFIGURE_ARGS+= --with-freetype
+.else
+CONFIGURE_ARGS+= --without-freetype
+.endif
+
+.ifdef(WITH_FORMSAVE)
+CONFIGURE_ARGS+= --enable-form-saving
+.else
+CONFIGURE_ARGS+= --disable-form-saving
+.endif
+
+.ifdef(WITH_JS)
+CONFIGURE_ARGS+= --enable-javascript
+.else
+CONFIGURE_ARGS+= --disable-javascript
+.endif
+
+MAN1= links.1
+PLIST_FILES+= bin/links
+
+.if !defined(WITHOUT_X11)
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/graphics/links.xpm ${PREFIX}/share/pixmaps/links.xpm
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/links-hacked/distinfo b/www/links-hacked/distinfo
new file mode 100644
index 000000000000..2abe3d5d8462
--- /dev/null
+++ b/www/links-hacked/distinfo
@@ -0,0 +1,2 @@
+SHA256 (links-hacked-101110.tar.gz) = 4a6fcff2992880c830b9a6caeb8396d5aa83ddacb00881f31ec9beba791c914e
+SIZE (links-hacked-101110.tar.gz) = 5796750
diff --git a/www/links-hacked/pkg-descr b/www/links-hacked/pkg-descr
new file mode 100644
index 000000000000..ac1558536394
--- /dev/null
+++ b/www/links-hacked/pkg-descr
@@ -0,0 +1,5 @@
+WWW browser Links well known and now hacked for more features including
+tabs, basic auth and toolbar, hot key for images, form entry saving, much
+better X fonts, etc.
+
+WWW: http://xray.sai.msu.ru/~karpov/links-hacked/