aboutsummaryrefslogtreecommitdiff
path: root/www/links1
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2013-03-12 15:51:14 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2013-03-12 15:51:14 +0000
commitc8d604a4629b5194779ee80ae8213feba4b9d4e7 (patch)
tree50fe706d06607e7120e602f021b3d90a71514484 /www/links1
parent65442089b44f7e05607fa0a3c78948cecb748717 (diff)
downloadports-c8d604a4629b5194779ee80ae8213feba4b9d4e7.tar.gz
ports-c8d604a4629b5194779ee80ae8213feba4b9d4e7.zip
Notes
Diffstat (limited to 'www/links1')
-rw-r--r--www/links1/Makefile2
-rw-r--r--www/links1/distinfo4
-rw-r--r--www/links1/files/patch-ab9
-rw-r--r--www/links1/files/patch-kbdbind.c29
4 files changed, 8 insertions, 36 deletions
diff --git a/www/links1/Makefile b/www/links1/Makefile
index f74eabedc9e8..82098b94da71 100644
--- a/www/links1/Makefile
+++ b/www/links1/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= links
-PORTVERSION= 0.98
+PORTVERSION= 1.03
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://artax.karlin.mff.cuni.cz/~mikulas/vyplody/links/download/ \
diff --git a/www/links1/distinfo b/www/links1/distinfo
index fcb98bc69720..83a9560c8ba4 100644
--- a/www/links1/distinfo
+++ b/www/links1/distinfo
@@ -1,2 +1,2 @@
-SHA256 (links-0.98.tar.gz) = 1d29f52df3da1c067cbbf4447825210e32f0a20cc5a9e6be2b6ad2c9c48bbaa8
-SIZE (links-0.98.tar.gz) = 545723
+SHA256 (links-1.03.tar.gz) = 32443c6f011216a8a43ed0806d9d23c1defdd19bc4b021ee00cda197782e175a
+SIZE (links-1.03.tar.gz) = 641917
diff --git a/www/links1/files/patch-ab b/www/links1/files/patch-ab
index c977c5f01f78..6f2f1d8d35d9 100644
--- a/www/links1/files/patch-ab
+++ b/www/links1/files/patch-ab
@@ -1,14 +1,15 @@
---- kbd.c.orig Thu Jan 11 13:26:36 2001
-+++ kbd.c Thu Jan 11 13:28:37 2001
-@@ -479,9 +479,9 @@
+--- kbd.c.orig 2013-03-12 19:47:22.000000000 +0400
++++ kbd.c 2013-03-12 19:47:24.000000000 +0400
+@@ -582,10 +582,10 @@
case 'B': ev.x = KBD_DOWN; break;
case 'C': ev.x = KBD_RIGHT; break;
case 'D': ev.x = KBD_LEFT; break;
- case 'F':
+ case 'F': ev.x = KBD_END; break;
+ case 'K':
case 'e': ev.x = KBD_END; break;
- case 'H':
+ case 'H': ev.x = KBD_HOME; break;
case 0: ev.x = KBD_HOME; break;
+ case 'V':
case 'I': ev.x = KBD_PAGE_UP; break;
- case 'G': ev.x = KBD_PAGE_DOWN; break;
diff --git a/www/links1/files/patch-kbdbind.c b/www/links1/files/patch-kbdbind.c
deleted file mode 100644
index 77f53a46c44d..000000000000
--- a/www/links1/files/patch-kbdbind.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- kbdbind.c.orig Wed Mar 20 09:22:48 2002
-+++ kbdbind.c Fri Apr 7 19:25:20 2006
-@@ -74,7 +74,7 @@
- long num;
- };
-
--static long strtonum(struct strtonum *table, char *s)
-+static long mystrtonum(struct strtonum *table, char *s)
- {
- struct strtonum *p;
- for (p = table; p->str; p++)
-@@ -90,7 +90,7 @@
- { "menu", KM_MENU },
- { NULL, 0 }
- };
-- return strtonum(table, s);
-+ return mystrtonum(table, s);
- }
-
- static long parse_key(unsigned char *s)
-@@ -124,7 +124,7 @@
- { "F12", KBD_F12 },
- { NULL, 0 }
- };
-- return (strlen(s) == 1) ? *s : strtonum(table, s);
-+ return (strlen(s) == 1) ? *s : mystrtonum(table, s);
- }
-
- static int parse_keystroke(unsigned char *s, long *x, long *y)