aboutsummaryrefslogtreecommitdiff
path: root/www/linux-c6-flashplugin11
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
commit05317facbedf1ed4566b56f4e09e6e4a49fc3f38 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /www/linux-c6-flashplugin11
parentf287925fdbb7ff7ab55ee8aaa28cf756fe49a296 (diff)
downloadports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.tar.gz
ports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.zip
Notes
Diffstat (limited to 'www/linux-c6-flashplugin11')
-rw-r--r--www/linux-c6-flashplugin11/Makefile54
-rw-r--r--www/linux-c6-flashplugin11/distinfo4
-rw-r--r--www/linux-c6-flashplugin11/pkg-descr10
-rw-r--r--www/linux-c6-flashplugin11/pkg-message7
-rw-r--r--www/linux-c6-flashplugin11/pkg-plist26
5 files changed, 101 insertions, 0 deletions
diff --git a/www/linux-c6-flashplugin11/Makefile b/www/linux-c6-flashplugin11/Makefile
new file mode 100644
index 000000000000..59cac98569f3
--- /dev/null
+++ b/www/linux-c6-flashplugin11/Makefile
@@ -0,0 +1,54 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= flashplugin
+PORTVERSION= 11.2r202.400
+CATEGORIES= www multimedia linux
+MASTER_SITES= http://fpdownload.macromedia.com/get/flashplayer/pdc/${PORTVERSION:C/r/\./}/:plugin \
+ LOCAL/nox:suplib
+PKGNAMEPREFIX= linux-${USE_LINUX}-
+DISTFILES= install_flash_player_11_linux.i386.tar.gz:plugin \
+ linux-f10-flashsupport-9.0.1.i386.tar.gz:suplib
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= eadler@FreeBSD.org
+COMMENT= Adobe Flash Player NPAPI Plugin
+
+ONLY_FOR_ARCHS= amd64 i386
+USE_LINUX= c6
+USE_LINUX_APPS= openssl curl cyrus-sasl2 nspr nss gtk2 #-alsalib libssh2 openldap
+WANT_GNOME= yes
+
+RESTRICTED= Redistribution not allowed
+RESTRICTED_FILES= ${DISTFILES:Nlinux-f10-flashsupport*:C/:[^:]+$//}
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+USES= webplugin:linux
+WEBPLUGIN_FILES= libflashplayer.so
+
+OPTIONS_DEFINE= GNOME
+GNOME_DESC= include gnome support for .desktop file
+
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNOME}
+USES+= desktop-file-utils
+INSTALLS_ICONS= yes
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' -e '/^NotShowIn=KDE/d' ${WRKDIR}/usr/share/applications/flash-player-properties.desktop
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WEBPLUGIN_DIR} ${STAGEDIR}${LINUXBASE}/usr/lib
+ ${INSTALL_LIB} ${WRKDIR}/libflashplayer.so ${STAGEDIR}${WEBPLUGIN_DIR}
+ ${INSTALL_LIB} ${WRKDIR}/libflashsupport.so ${STAGEDIR}${LINUXBASE}/usr/lib
+ ${INSTALL_PROGRAM} ${WRKDIR}/usr/bin/flash-player-properties ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKDIR}/usr/share/applications/flash-player-properties.desktop ${STAGEDIR}${DESKTOPDIR}
+ (cd ${WRKDIR}/usr/share/icons && ${COPYTREE_SHARE} hicolor ${STAGEDIR}${PREFIX}/share/icons)
+
+.include <bsd.port.mk>
diff --git a/www/linux-c6-flashplugin11/distinfo b/www/linux-c6-flashplugin11/distinfo
new file mode 100644
index 000000000000..9f1746f265c4
--- /dev/null
+++ b/www/linux-c6-flashplugin11/distinfo
@@ -0,0 +1,4 @@
+SHA256 (flashplugin/11.2r202.400/install_flash_player_11_linux.i386.tar.gz) = d0ac17fa50069520e1aee59e3aa893ebec3cfdcecb4f81aba040662352fd6ef7
+SIZE (flashplugin/11.2r202.400/install_flash_player_11_linux.i386.tar.gz) = 6927109
+SHA256 (flashplugin/11.2r202.400/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 4a309b1a326bd2212cc72480628659e5a7fd61d9e0572cb7350c206f030955bf
+SIZE (flashplugin/11.2r202.400/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 3455
diff --git a/www/linux-c6-flashplugin11/pkg-descr b/www/linux-c6-flashplugin11/pkg-descr
new file mode 100644
index 000000000000..9c9dcd2de5d8
--- /dev/null
+++ b/www/linux-c6-flashplugin11/pkg-descr
@@ -0,0 +1,10 @@
+This is the official Flash Player from Adobe. This plugin enables
+you to see .swf and .spl files on the 'net from your Opera, Mozilla or
+Firefox sessions.
+
+Please see the Adobe home page for more information.
+
+FreeBSD Flash License Agreement:
+ http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/96374
+
+WWW: http://www.adobe.com/
diff --git a/www/linux-c6-flashplugin11/pkg-message b/www/linux-c6-flashplugin11/pkg-message
new file mode 100644
index 000000000000..98294fcb3e9b
--- /dev/null
+++ b/www/linux-c6-flashplugin11/pkg-message
@@ -0,0 +1,7 @@
+If this is your first time installing flash each user must run:
+
+ nspluginwrapper -v -a -i
+
+If you are updating flash each user must run:
+
+ nspluginwrapper -v -a -u
diff --git a/www/linux-c6-flashplugin11/pkg-plist b/www/linux-c6-flashplugin11/pkg-plist
new file mode 100644
index 000000000000..1d74fbb9615a
--- /dev/null
+++ b/www/linux-c6-flashplugin11/pkg-plist
@@ -0,0 +1,26 @@
+bin/flash-player-properties
+%%WEBPLUGIN_DIR%%/libflashplayer.so
+share/applications/flash-player-properties.desktop
+share/icons/hicolor/16x16/apps/flash-player-properties.png
+share/icons/hicolor/22x22/apps/flash-player-properties.png
+share/icons/hicolor/24x24/apps/flash-player-properties.png
+share/icons/hicolor/32x32/apps/flash-player-properties.png
+share/icons/hicolor/48x48/apps/flash-player-properties.png
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry %%WEBPLUGIN_DIR%%
+@cwd /compat/linux
+usr/lib/libflashsupport.so
+@dirrmtry usr/lib
+@dirrmtry usr
+@cwd %%RESETPREFIX%%