aboutsummaryrefslogtreecommitdiff
path: root/www/linux-lesstif-ns/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-01-29 15:33:06 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-01-29 15:33:06 +0000
commitd9d18678eb2c2a63f1769de55e6c77ce85a0f3d4 (patch)
tree7b3bc276fb0f295844bbe1cdc03da08debeb728d /www/linux-lesstif-ns/Makefile
parent9eaafa8e83038ae4fb254e082cd9df8832eaff8f (diff)
downloadports-d9d18678eb2c2a63f1769de55e6c77ce85a0f3d4.tar.gz
ports-d9d18678eb2c2a63f1769de55e6c77ce85a0f3d4.zip
Notes
Diffstat (limited to 'www/linux-lesstif-ns/Makefile')
-rw-r--r--www/linux-lesstif-ns/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/www/linux-lesstif-ns/Makefile b/www/linux-lesstif-ns/Makefile
index 0e164c05c7b2..4f4bab53ec08 100644
--- a/www/linux-lesstif-ns/Makefile
+++ b/www/linux-lesstif-ns/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lesstif
-PORTVERSION= 0.91.0
+PORTVERSION= 0.92.6
CATEGORIES= www x11-toolkits linux
MASTER_SITES= ftp://ftp.lesstif.org/pub/hungry/lesstif/srcdist/ \
ftp://ftp.hungry.com/pub/hungry/lesstif/srcdist/ \
@@ -23,14 +23,21 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LINUXBASE}/usr/bin/cc:${PORTSDIR}/devel/linux_devtools
+USE_BZIP2= yes
USE_LINUX_PREFIX= yes
PREFIX= ${LINUXBASE}${X11BASE}
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --host=${MACHINE_ARCH}--linux-gnu --enable-shared --enable-production \
- --disable-build-20 --disable-debug --no-recursion \
+CONFIGURE_ARGS= --host=${MACHINE_ARCH}--linux-gnu \
+ --enable-shared --enable-production \
+ --enable-build-12 --enable-default-12 --disable-build-20 \
+ --disable-debug --no-recursion \
--without-motif --disable-build-Xlt --disable-build-Xbae
GMAKE= ${LINUXBASE}/usr/bin/make
+pre-configure:
+ @${ECHO_MSG} "*** Loading the Linux loadable kernel module (Error will be ignored) ***"
+ -@linux
+
do-build:
cd ${WRKSRC}/lib/Xm && ${GMAKE}