aboutsummaryrefslogtreecommitdiff
path: root/www/linux-lesstif-ns
diff options
context:
space:
mode:
authorR. Imura <imura@FreeBSD.org>2000-05-07 06:05:24 +0000
committerR. Imura <imura@FreeBSD.org>2000-05-07 06:05:24 +0000
commit6b256607d0fdcf5ab6f38def497496e5461a1746 (patch)
tree4f9b59cb8dbebffbb5f6703ca59fb46f96767eaf /www/linux-lesstif-ns
parent47fc61855b13f3bb0bf553876f87554b9bb5d76d (diff)
downloadports-6b256607d0fdcf5ab6f38def497496e5461a1746.tar.gz
ports-6b256607d0fdcf5ab6f38def497496e5461a1746.zip
Notes
Diffstat (limited to 'www/linux-lesstif-ns')
-rw-r--r--www/linux-lesstif-ns/Makefile48
-rw-r--r--www/linux-lesstif-ns/distinfo2
-rw-r--r--www/linux-lesstif-ns/pkg-comment1
-rw-r--r--www/linux-lesstif-ns/pkg-descr14
-rw-r--r--www/linux-lesstif-ns/pkg-plist4
5 files changed, 69 insertions, 0 deletions
diff --git a/www/linux-lesstif-ns/Makefile b/www/linux-lesstif-ns/Makefile
new file mode 100644
index 000000000000..a45a7232c9be
--- /dev/null
+++ b/www/linux-lesstif-ns/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: linux-lesstif-ns
+# Date created: 7 May 2000
+# Whom: imura@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= lesstif
+PORTVERSION= 0.90.5
+CATEGORIES= www x11-toolkits linux
+MASTER_SITES= ftp://ftp.lesstif.org/pub/hungry/lesstif/srcdist/ \
+ ftp://ftp.hungry.com/pub/hungry/lesstif/srcdist/ \
+ ftp://ftp.fu-berlin.de/unix/X11/gui/lesstif/srcdist/ \
+ ftp://ftp.win.or.jp/pub/X11/misc/lesstif/srcdist/
+PKGNAMEPREFIX= linux-
+PKGNAMESUFFIX= -ns
+
+PATCH_SITES= http://cgi.shikoku.ne.jp/~fun/srpms/
+PATCHFILES= ${DISTNAME}-i18n.patch
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= imura@FreeBSD.org
+
+BUILD_DEPENDS= ${LINUX_BASE}/usr/bin/cc:${PORTSDIR}/devel/linux_devtools
+RUN_DEPENDS= ${LINUX_BASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+
+LINUX_BASE= /compat/linux
+PREFIX= ${LINUX_BASE}${X11BASE}
+NO_MTREE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --host=${MACHINE_ARCH}--linux-gnu --enable-shared --enable-production \
+ --disable-build-20 --disable-debug --no-recursion \
+ --without-motif --disable-build-Xlt --disable-build-Xbae
+GMAKE= ${LINUX_BASE}/usr/bin/make
+
+do-build:
+ cd ${WRKSRC}/lib/Xm && ${GMAKE}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/lib/Xm/.libs/libXm.so.1.0.2 \
+ ${PREFIX}/lib/libXm-ns.so.1.0.2
+ ${LN} -sf libXm-ns.so.1.0.2 ${PREFIX}/lib/libXm.so.1
+ ${LN} -sf libXm.so.1 ${PREFIX}/lib/libXm.so
+ ${LINUX_BASE}/sbin/ldconfig
+
+.include <bsd.port.mk>
+
+CONFIGURE_ENV+= ${LINUX_BASE}/bin/bash
diff --git a/www/linux-lesstif-ns/distinfo b/www/linux-lesstif-ns/distinfo
new file mode 100644
index 000000000000..11a571082fac
--- /dev/null
+++ b/www/linux-lesstif-ns/distinfo
@@ -0,0 +1,2 @@
+MD5 (lesstif-0.90.5.tar.gz) = 0202d78fb7eb8a16146a77031053d690
+MD5 (lesstif-0.90.5-i18n.patch) = 0380e6f2bcfac785593af50d5036d0c2
diff --git a/www/linux-lesstif-ns/pkg-comment b/www/linux-lesstif-ns/pkg-comment
new file mode 100644
index 000000000000..da9938c3cd82
--- /dev/null
+++ b/www/linux-lesstif-ns/pkg-comment
@@ -0,0 +1 @@
+Clone of the Motif library mostly for linux-netscape4
diff --git a/www/linux-lesstif-ns/pkg-descr b/www/linux-lesstif-ns/pkg-descr
new file mode 100644
index 000000000000..157d49479ae5
--- /dev/null
+++ b/www/linux-lesstif-ns/pkg-descr
@@ -0,0 +1,14 @@
+LessTif is a API compatible clone of the Motif.
+Currently Motif (statically linked by Netscape4) has a critical bug
+around multi-byte handling in TextWidget such as <input type=text>
+and <textarea> fields. This port will solve the above problem of
+linux-netscape (like www/libxpg4-ns for our native Netscape).
+Instead, it brings various problems (behaviour of scroll bar,
+a size of textarea, ..) because lesstif is still in progress and
+not a perfect clone of Motif.
+To activate this port, make sure that you use netscape-dynMotif instead
+of communicator(navigator)-linux-x.xx.bin in ${LOCALBASE}/lib/netscape-linux/.
+Patches are created by "fun" <fun@shikoku.ne.jp>
+
+- R. Imura
+imura@FreeBSD.org
diff --git a/www/linux-lesstif-ns/pkg-plist b/www/linux-lesstif-ns/pkg-plist
new file mode 100644
index 000000000000..11b772af798a
--- /dev/null
+++ b/www/linux-lesstif-ns/pkg-plist
@@ -0,0 +1,4 @@
+lib/libXm-ns.so.1.0.2
+lib/libXm.so
+lib/libXm.so.1
+@exec /compat/linux/sbin/ldconfig