aboutsummaryrefslogtreecommitdiff
path: root/www/linux-mplayer-plugin/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-09-07 16:50:46 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-09-07 16:50:46 +0000
commit4df0317f9eca1b66beea4ccff13063246a4e740b (patch)
tree62346d9f639ee855f8d756f823cf35653edf960b /www/linux-mplayer-plugin/Makefile
parent484cafa3947117530b1c498ccc94878c5f9b1e43 (diff)
downloadports-4df0317f9eca1b66beea4ccff13063246a4e740b.tar.gz
ports-4df0317f9eca1b66beea4ccff13063246a4e740b.zip
Notes
Diffstat (limited to 'www/linux-mplayer-plugin/Makefile')
-rw-r--r--www/linux-mplayer-plugin/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/linux-mplayer-plugin/Makefile b/www/linux-mplayer-plugin/Makefile
index bef6a14c5f0c..376ad05f417a 100644
--- a/www/linux-mplayer-plugin/Makefile
+++ b/www/linux-mplayer-plugin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mplayerplug-in
-PORTVERSION= 3.25
+PORTVERSION= 3.31
DISTVERSIONSUFFIX= -fc4
CATEGORIES= www multimedia
MASTER_SITES= SF
@@ -15,10 +15,15 @@ PKGNAMEPREFIX= linux-
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= Embed MPlayer into browser
-RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
+RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
+ ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
+ ${LINUXBASE}/usr/lib/libatk-1.0.so.0:${PORTSDIR}/accessibility/linux-atk \
+ ${LINUXBASE}/usr/lib/libpangoxft-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango\
+ ${LINUXBASE}/usr/lib/libgobject-2.0.so.0:${PORTSDIR}/devel/linux-glib2
NO_BUILD= yes
USE_LINUX_RPM= yes
+USE_XLIB= yes
LINUX_DIST= fedora
LINUX_DIST_VER= 4
PREFIX?= ${LOCALBASE}
@@ -26,7 +31,7 @@ PREFIX?= ${LOCALBASE}
USE_NPAPI= linux
NPAPI_WRKSRC= ${WRKDIR}/usr/lib/mozilla/plugins
NPAPI_FILES= ${PLUGINS_EXT:S/^/${PORTNAME}/}
-PLUGINS_EXT= .so .xpt -gmp.so -gmp.xpt -qt.so -qt.xpt -rm.so -rm.xpt -wmp.so -wmp.xpt
+PLUGINS_EXT= .so .xpt -dvx.so -dvx.xpt -qt.so -qt.xpt -rm.so -rm.xpt -wmp.so -wmp.xpt
.include "${.CURDIR}/Makefile.npapi"
.include <bsd.port.mk>