aboutsummaryrefslogtreecommitdiff
path: root/www/linux-mplayer-plugin
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-12-14 19:16:17 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-12-14 19:16:17 +0000
commitee0b82ad4e8ef3ed135616edab4df387619130cd (patch)
tree90433f9dc44bf901c89881ea987fe1d98969e3eb /www/linux-mplayer-plugin
parented175a502c94dbecbec7dbdfcf10a4266b938716 (diff)
downloadports-ee0b82ad4e8ef3ed135616edab4df387619130cd.tar.gz
ports-ee0b82ad4e8ef3ed135616edab4df387619130cd.zip
Notes
Diffstat (limited to 'www/linux-mplayer-plugin')
-rw-r--r--www/linux-mplayer-plugin/Makefile.npapi34
1 files changed, 19 insertions, 15 deletions
diff --git a/www/linux-mplayer-plugin/Makefile.npapi b/www/linux-mplayer-plugin/Makefile.npapi
index 2b9889cfdad8..e7ce250d4b7a 100644
--- a/www/linux-mplayer-plugin/Makefile.npapi
+++ b/www/linux-mplayer-plugin/Makefile.npapi
@@ -16,8 +16,8 @@
# NPAPI_DIRS - List of directories in npapi archive. This is used to produce
# PLIST_DIRS.
# PORTNAME, PORTVERSION, DISTVERSIONSUFFIX, CATEGORIES, MAINTAINER, COMMENT
-# - These should all be set manually for port to be functional. See
-# ${PORTSDIR}/Mk/bsd.port.mk for details.
+# - These should all be set manually for port to be functional.
+# See ${PORTSDIR}/Mk/bsd.port.mk for details.
# NPAPI_LIBDIR - Name of the directory to install plugins in.
# Default: ${PREFIX}/lib/npapi
# NPAPI_NPAPIDIR
@@ -31,22 +31,24 @@
# do-install target being set to a default.
# WITH_NPAPI - A user-tunable variable, determines which apps should
# plugin be made available for. Can be set to a list of
-# apps, same as USE_NPAPI, and/or to "ext:app[,app,app,...]" tuples.
-# ext should be a portname. If ext starts and ends with a slash
-# (`/'), it is treated as an extended regular expression (see
-# re_format(7)). Right of the colon should be a list of apps in
-# the same format as USE_NPAPI, but comma- instead of whitespace-
-# delimited. If no matching tuples for an plugin are found,
-# WITH_NPAPI is scanned for non tuple-records which are then treated
-# as a USE_NPAPI list. If several tuples match, the last non-regexp
-# one takes precedence, then the last regexp one.
+# apps, same as USE_NPAPI, and/or to "ext:app[,app,app,...]"
+# tuples. ext should be a portname. If ext starts and ends with
+# a slash (`/'), it is treated as an extended regular expression
+# (see re_format(7)). Right of the colon should be a list of
+# apps in the same format as USE_NPAPI, but comma- instead of
+# whitespace-delimited. If no matching tuples for an plugin are
+# found, WITH_NPAPI is scanned for non tuple-records which are
+# then treated as a USE_NPAPI list. If several tuples match, the
+# last non-regexp one takes precedence, then the last regexp
+# one.
#
# This Makefile is an alpha-version of the new npapi infrastructure.
#
# Npapi's are installed into ${LOCALBASE}/lib/npapi/${NPAPI_ID} by default and
-# links are made to all apps which have the engine (firefox, thunderbird and flock
-# at the moment). relink and relink-all targets can be invoked to refarm the links
-# of a single plugins or all installed plugins accordingly.
+# links are made to all apps which have the engine (firefox, thunderbird, flock,
+# netscape messenger and navigator at the moment). relink and relink-all targets
+# can be invoked to refarm the links of a single plugins or all installed
+# plugins accordingly.
#
# npapi ports do not depend on their master applications. You can install an
# plugin before the app and run relink when the app is present.
@@ -59,12 +61,14 @@ NPAPI_PKGDEINSTALL?= ${WRKDIR}/npapi-pkg-deinstall
PKGINSTALL?= ${NPAPI_PKGINSTALL}
PKGDEINSTALL?= ${NPAPI_PKGDEINSTALL}
-NPAPI_APPS_ALL_WC= *mozilla* *firefox* *flock* *seamonkey* *opera*
+NPAPI_APPS_ALL_WC= *mozilla* *firefox* *flock* *seamonkey* *opera* \
+ *netscape-messenger* *netscape-navigator*
NPAPI_APPS_ALL_WC_LINUX= ${NPAPI_APPS_ALL_WC:S/^*/linux-/}
NPAPI_APPS_ALL_WC_NATIVE= ${NPAPI_APPS_ALL_WC:S/^*//}
NPAPI_APPS_ALL= firefox firefox-devel linux-firefox linux-firefox-devel \
flock flock-devel linux-flock linux-flock-devel \
mozilla mozilla-devel linux-mozilla \
+ linux-netscape-messenger linux-netscape-navigator \
nvu linux-nvu \
opera opera-devel linux-opera linux-opera-devel \
seamonkey seamonkey-devel linux-seamonkey linux-seamonkey-devel \