aboutsummaryrefslogtreecommitdiff
path: root/www/linux-opera/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-22 09:24:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-22 09:24:45 +0000
commit1f9f8fa79cdd16599468e96fe2428c3defb0edb1 (patch)
tree9ace78d0e8075e6c58887af57bf86a95b8ba2a82 /www/linux-opera/Makefile
parent6ed433cea3bf4ffb30f1f0c3e018ab662ddb876e (diff)
downloadports-1f9f8fa79cdd16599468e96fe2428c3defb0edb1.tar.gz
ports-1f9f8fa79cdd16599468e96fe2428c3defb0edb1.zip
Notes
Diffstat (limited to 'www/linux-opera/Makefile')
-rw-r--r--www/linux-opera/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index c2a9fd0ec0dc..9296cc4dcee1 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= opera
-PORTVERSION= 7.22.20031103
+PORTVERSION= 7.23.20031119
CATEGORIES= www linux
-MASTER_SITES= ftp://ftp.opera.com/pub/opera/linux/722/final/en/i386/static/
+MASTER_SITES= ftp://ftp.opera.com/pub/opera/linux/723/final/en/i386/static/
PKGNAMEPREFIX= linux-
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.2003/-2003/}.1-static-qt.i386-en
@@ -20,8 +20,15 @@ RESTRICTED= "not redistributable; commercial software"
RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXm.so.2:${PORTSDIR}/x11-toolkits/linux-openmotif
-USE_BZIP2= yes
+.if defined(WITH_XFT2)
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrandr.so.2:${PORTSDIR}/x11/linux-XFree86-libs \
+ ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
+.else
USE_LINUX= yes
+.endif
+
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
@@ -61,6 +68,13 @@ PLIST_SUB+= GNOMELNK:=""
PLIST_SUB+= GNOMELNK:="@comment "
.endif
+pre-everything::
+.if !defined(WITH_XFT2)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} " "
+ @${ECHO_MSG} "WITH_XFT2=yes for use Xft2 (requires linux_base-8) with nicer anti-aliased fonts."
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \