aboutsummaryrefslogtreecommitdiff
path: root/www/linux-opera7
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2000-12-06 16:57:04 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2000-12-06 16:57:04 +0000
commit2b74c268f9b8fbf706079440d61775e77cd45ff8 (patch)
tree6bdd69dd056258b5789b39be2939b84a4fe62f76 /www/linux-opera7
parent3b8f3826324a3792169a974e4fbab43472ac00af (diff)
I forgot the sed magic for opera.sh.
Spotted by: jedgar
Notes
Notes: svn path=/head/; revision=35723
Diffstat (limited to 'www/linux-opera7')
-rw-r--r--www/linux-opera7/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/linux-opera7/Makefile b/www/linux-opera7/Makefile
index ab8f8eba275a..fbc80b97a964 100644
--- a/www/linux-opera7/Makefile
+++ b/www/linux-opera7/Makefile
@@ -17,9 +17,13 @@ RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_base
NO_BUILD= yes
+do-configure:
+ ${SED} 's|%%PREFIX%%|${PREFIX}|; s|%%DISTNAME%%|${DISTNAME}|' \
+ <${FILESDIR}/opera.sh >${WRKDIR}/opera.sh
+
do-install:
(cd ${WRKDIR} && \
tar cf - ${DISTNAME} | tar --unlink -xpf - -C ${PREFIX})
- ${INSTALL_SCRIPT} ${FILESDIR}/opera.sh ${PREFIX}/bin/opera
+ ${INSTALL_SCRIPT} ${WRKDIR}/opera.sh ${PREFIX}/bin/opera
.include <bsd.port.mk>