aboutsummaryrefslogtreecommitdiff
path: root/www/linux-opera7
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2001-03-08 11:12:09 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2001-03-08 11:12:09 +0000
commita8d6e8bb1412fc7289b46881132bc2a2c87fd496 (patch)
treed89f7eed97d8662a3c05c31fc8452d33aa1696a2 /www/linux-opera7
parentaae940f110010422231793d3f8d933fa0c9ed7fb (diff)
downloadports-a8d6e8bb1412fc7289b46881132bc2a2c87fd496.tar.gz
ports-a8d6e8bb1412fc7289b46881132bc2a2c87fd496.zip
Notes
Diffstat (limited to 'www/linux-opera7')
-rw-r--r--www/linux-opera7/Makefile1
-rw-r--r--www/linux-opera7/pkg-install27
2 files changed, 27 insertions, 1 deletions
diff --git a/www/linux-opera7/Makefile b/www/linux-opera7/Makefile
index c5faed373709..3f7dd54e43aa 100644
--- a/www/linux-opera7/Makefile
+++ b/www/linux-opera7/Makefile
@@ -14,7 +14,6 @@ DISTNAME= opera-5.0-b6-20010212.017-static.i386
MAINTAINER= des@FreeBSD.org
IS_INTERACTIVE= YES
-NO_PACKAGE= "User must agree to license prior to installation."
RUN_DEPENDS= ${LINUXBASE}/lib/ld.so:${PORTSDIR}/emulators/linux_base \
${LINUXBASE}/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png \
diff --git a/www/linux-opera7/pkg-install b/www/linux-opera7/pkg-install
new file mode 100644
index 000000000000..18e1ca019af2
--- /dev/null
+++ b/www/linux-opera7/pkg-install
@@ -0,0 +1,27 @@
+#!/bin/sh
+
+case $2 in
+ PRE-INSTALL)
+ ${PAGER:-more} share/doc/opera/LICENSE
+ echo
+ echo
+ echo -n 'Do you agree to the terms of the license? '
+ read answer
+ case ${answer} in
+ [Yy]|[Yy][Ee][Ss])
+ exit 0
+ ;;
+ *)
+ exit 1
+ ;;
+ esac
+ ;;
+ POST-INSTALL)
+ exit 0
+ ;;
+ *)
+ echo "Unexpected Argument $2!!!"
+ exit 1
+ ;;
+esac
+