aboutsummaryrefslogtreecommitdiff
path: root/www/linuxpluginwrapper
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-07-06 17:37:05 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-07-06 17:37:05 +0000
commit9378ecb661dcc1e5c841f3b4c438e7ef9b907be4 (patch)
tree15c1be6e105c0cb0ee852cf432d42422ff4694ae /www/linuxpluginwrapper
parentf50714a28b6e96f1f81e5bf10b4bd086d4b041d9 (diff)
downloadports-9378ecb661dcc1e5c841f3b4c438e7ef9b907be4.tar.gz
ports-9378ecb661dcc1e5c841f3b4c438e7ef9b907be4.zip
Notes
Diffstat (limited to 'www/linuxpluginwrapper')
-rw-r--r--www/linuxpluginwrapper/Makefile23
1 files changed, 19 insertions, 4 deletions
diff --git a/www/linuxpluginwrapper/Makefile b/www/linuxpluginwrapper/Makefile
index 02b62476fba6..4385b625f93b 100644
--- a/www/linuxpluginwrapper/Makefile
+++ b/www/linuxpluginwrapper/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linuxpluginwrapper
PORTVERSION= 20040310
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www linux
MASTER_SITES= http://people.FreeBSD.org/~nork/distfiles/ \
${MASTER_SITE_LOCAL}
@@ -18,15 +18,23 @@ COMMENT= A wrapper allowing use of linux-plugins with native applications
.include <bsd.port.pre.mk>
-RUN_DEPENDS= ${LOCALBASE}/Acrobat5/Browsers/intellinux/nppdf.so:${PORTSDIR}/print/acroread5 \
- ${LOCALBASE}/lib/linux-flashplugin6/libflashplayer.so:${PORTSDIR}/www/linux-flashplugin6
+.if !defined(WITHOUT_PLUGINS)
+RUN_DEPENDS= ${LOCALBASE}/lib/linux-flashplugin6/libflashplayer.so:${PORTSDIR}/www/linux-flashplugin6
+.if ${OSVERSION} >= 500000
+RUN_DEPENDS+= ${LOCALBASE}/Acrobat5/Browsers/intellinux/nppdf.so:${PORTSDIR}/print/acroread5
+.else
+USE_MOTIF= yes
+.endif
+.endif
ONLY_FOR_ARCHS= i386
USE_XLIB= yes
-USE_MOTIF= yes
USE_REINPLACE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
+.if defined(WITHOUT_PLUGINS)
+PLIST= ${WRKDIR}/pkg-plist
+.endif
CONFLICTS= flashpluginwrapper-*
.if ${OSVERSION} >= 500000
@@ -71,15 +79,22 @@ post-build:
-e '/^%%LIBMAPCONF%%$$/r ${LIBMAPCONF}' \
-e '/^%%LIBMAPCONF%%$$/d' \
< ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+.if defined(WITHOUT_PLUGINS)
+ @${SED} -e "/exec/d" ${.CURDIR}/pkg-plist > ${PLIST}
+.endif
pre-install:
@${MKDIR} ${X11BASE}/lib/browser_plugins
+.if !defined(WITHOUT_PLUGINS)
+.if ${OSVERSION} >= 500000
@${LN} -sf ${LOCALBASE}/Acrobat5/Browsers/intellinux/nppdf.so \
${X11BASE}/lib/browser_plugins/
+.endif
@${LN} -sf ${LOCALBASE}/lib/linux-flashplugin6/flashplayer.xpt \
${X11BASE}/lib/browser_plugins/
@${LN} -sf ${LOCALBASE}/lib/linux-flashplugin6/libflashplayer.so \
${X11BASE}/lib/browser_plugins/
+.endif
post-install:
@${CAT} ${PKGMESSAGE}