aboutsummaryrefslogtreecommitdiff
path: root/www/lionwiki
diff options
context:
space:
mode:
authorYi-Jheng Lin <yzlin@FreeBSD.org>2009-11-09 12:13:18 +0000
committerYi-Jheng Lin <yzlin@FreeBSD.org>2009-11-09 12:13:18 +0000
commit13fc082f56ae812bdd08388a7f5c330fcb900978 (patch)
tree98dc9acf0e8073947f4422e99062d4efa632cfa0 /www/lionwiki
parent20d521f21422e014f61b312e78b3fdc9276168bc (diff)
downloadports-13fc082f56ae812bdd08388a7f5c330fcb900978.tar.gz
ports-13fc082f56ae812bdd08388a7f5c330fcb900978.zip
Notes
Diffstat (limited to 'www/lionwiki')
-rw-r--r--www/lionwiki/Makefile42
-rw-r--r--www/lionwiki/distinfo3
-rw-r--r--www/lionwiki/files/pkg-message.in24
-rw-r--r--www/lionwiki/pkg-descr6
-rw-r--r--www/lionwiki/pkg-plist70
5 files changed, 145 insertions, 0 deletions
diff --git a/www/lionwiki/Makefile b/www/lionwiki/Makefile
new file mode 100644
index 000000000000..09ceab04ccbf
--- /dev/null
+++ b/www/lionwiki/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: lionwiki
+# Date created: 2009-10-07
+# Whom: Sylvio Cesar <scjamorim@bsd.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lionwiki
+PORTVERSION= 3.1.0
+CATEGORIES= www
+MASTER_SITES= http://lionwiki.0o.cz/download/${PORTVERSION}/
+
+MAINTAINER= scjamorim@bsd.com.br
+COMMENT= Minimalis wiki, extensible, templatable and file based
+
+USE_BZIP2= yes
+USE_PHP= session ctype
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+ROOTFILES= config.php index.php
+ROOTDIRS= lang plugins templates var
+SUB_FILES= pkg-message
+
+post-patch:
+ @(cd ${WRKSRC} && ${MV} config.php config.php.sample)
+
+do-install:
+ @${MKDIR} ${WWWDIR}
+ @${INSTALL_DATA} ${WRKSRC}/config.php.sample ${WWWDIR}/
+ @if [ ! -f ${WWWDIR}/config.php ]; then \
+ ${CP} -p ${WWWDIR}/config.php.sample ${WWWDIR}/config.php; \
+ fi
+ @${INSTALL_DATA} ${WRKSRC}/index.php ${WWWDIR}/
+.for dirs in ${ROOTDIRS}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dirs} ${WWWDIR}/ )
+.endfor
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+.include <bsd.port.mk>
diff --git a/www/lionwiki/distinfo b/www/lionwiki/distinfo
new file mode 100644
index 000000000000..207a00c6fd2e
--- /dev/null
+++ b/www/lionwiki/distinfo
@@ -0,0 +1,3 @@
+MD5 (lionwiki-3.1.0.tar.bz2) = 06267849187f985c9c44a9fcedcd699b
+SHA256 (lionwiki-3.1.0.tar.bz2) = 3c6a9c8c6cbbe59ad4350f389ed2c1ca9a5c1d867c15c09b859ee31149158200
+SIZE (lionwiki-3.1.0.tar.bz2) = 49324
diff --git a/www/lionwiki/files/pkg-message.in b/www/lionwiki/files/pkg-message.in
new file mode 100644
index 000000000000..cf8c016ef33a
--- /dev/null
+++ b/www/lionwiki/files/pkg-message.in
@@ -0,0 +1,24 @@
+=============================================================================
+
+Make sure index.php is part of your DirectoryIndex.
+
+You should add the following to your Apache configuration file:
+
+ Alias /lionwiki "%%WWWDIR%%/"
+ <Directory "%%WWWDIR%%/">
+ Order allow,deny
+ Allow from all
+ </Directory>
+
+Try to change the template for a better appearance.
+The templates are in:
+
+ "%%WWWDIR%%/templates"
+
+i.e: To use the wikiss template.
+
+The config file to lionwiki is in:
+
+ "%%WWWDIR%%/config.php"
+
+=============================================================================
diff --git a/www/lionwiki/pkg-descr b/www/lionwiki/pkg-descr
new file mode 100644
index 000000000000..3f25d282934a
--- /dev/null
+++ b/www/lionwiki/pkg-descr
@@ -0,0 +1,6 @@
+LionWiki is a minimalis Wiki engine programmed in PHP. It's extensible,
+templatable, file based (it doesn't need database like MySQL) and requires
+just one file to function. It's suitable for small websites, personal
+notebooks or journals.
+
+WWW: http://lionwiki.0o.cz
diff --git a/www/lionwiki/pkg-plist b/www/lionwiki/pkg-plist
new file mode 100644
index 000000000000..09d7d303377e
--- /dev/null
+++ b/www/lionwiki/pkg-plist
@@ -0,0 +1,70 @@
+@unexec if cmp -s %D/%%WWWDIR%%/config.php %D/%%WWWDIR%%/config.php.sample; then rm -f %D/%%WWWDIR%%/config.php; else %%ECHO_MSG%% "===> Customized %D/%%WWWDIR%%/config.php has not been removed"; fi
+%%WWWDIR%%/config.php.sample
+@exec if [ ! -f %D/%%WWWDIR%%/config.php ] ; then cp -p %D/%F %B/config.php; fi
+%%WWWDIR%%/index.php
+%%WWWDIR%%/lang/ar.php
+%%WWWDIR%%/lang/cs.php
+%%WWWDIR%%/lang/de-ch.php
+%%WWWDIR%%/lang/de.php
+%%WWWDIR%%/lang/en.php
+%%WWWDIR%%/lang/eo.php
+%%WWWDIR%%/lang/es.php
+%%WWWDIR%%/lang/fi.php
+%%WWWDIR%%/lang/fr.php
+%%WWWDIR%%/lang/he.php
+%%WWWDIR%%/lang/hr.php
+%%WWWDIR%%/lang/hu.php
+%%WWWDIR%%/lang/it.php
+%%WWWDIR%%/lang/nl.php
+%%WWWDIR%%/lang/pt-br.php
+%%WWWDIR%%/lang/pt.php
+%%WWWDIR%%/lang/sk.php
+%%WWWDIR%%/lang/zh-tw.php
+%%WWWDIR%%/plugins/AjaxEditing/ajax.js
+%%WWWDIR%%/plugins/AjaxEditing/template.html
+%%WWWDIR%%/plugins/BetterEditor/bettereditor.js
+%%WWWDIR%%/plugins/Captcha/cs_questions.txt
+%%WWWDIR%%/plugins/Captcha/en_questions.txt
+%%WWWDIR%%/plugins/Comments/comments.css
+%%WWWDIR%%/plugins/Comments/comments.js
+%%WWWDIR%%/plugins/Comments/template.html
+%%WWWDIR%%/plugins/InlineDiff/diff.php
+%%WWWDIR%%/plugins/InlineDiff/inline.php
+%%WWWDIR%%/plugins/InlineDiff/native.php
+%%WWWDIR%%/plugins/InlineDiff/renderer.php
+%%WWWDIR%%/plugins/Menu/default.html
+%%WWWDIR%%/plugins/wkp_Admin.php
+%%WWWDIR%%/plugins/wkp_AjaxEditing.php
+%%WWWDIR%%/plugins/wkp_BetterEditor.php
+%%WWWDIR%%/plugins/wkp_Captcha.php
+%%WWWDIR%%/plugins/wkp_Comments.php
+%%WWWDIR%%/plugins/wkp_Footnotes.php
+%%WWWDIR%%/plugins/wkp_Index.php
+%%WWWDIR%%/plugins/wkp_InlineDiff.php
+%%WWWDIR%%/plugins/wkp_ListPlugins.php
+%%WWWDIR%%/plugins/wkp_Menu.php
+%%WWWDIR%%/plugins/wkp_Meta.php
+%%WWWDIR%%/plugins/wkp_PageVersions.php
+%%WWWDIR%%/plugins/wkp_RSS.php
+%%WWWDIR%%/plugins/wkp_SelectLanguage.php
+%%WWWDIR%%/plugins/wkp_SelectTemplate.php
+%%WWWDIR%%/plugins/wkp_Tables.php
+%%WWWDIR%%/plugins/wkp_Tags.php
+%%WWWDIR%%/plugins/wkp_WhatLinksHere.php
+%%WWWDIR%%/templates/dandelion.html
+%%WWWDIR%%/templates/minimal.html
+%%WWWDIR%%/templates/print.html
+%%WWWDIR%%/templates/red.html
+%%WWWDIR%%/templates/terminal.html
+%%WWWDIR%%/templates/wikiss.html
+@dirrm %%WWWDIR%%/var
+@dirrm %%WWWDIR%%/templates
+@dirrm %%WWWDIR%%/plugins/Menu
+@dirrm %%WWWDIR%%/plugins/InlineDiff
+@dirrm %%WWWDIR%%/plugins/Comments
+@dirrm %%WWWDIR%%/plugins/Captcha
+@dirrm %%WWWDIR%%/plugins/BetterEditor
+@dirrm %%WWWDIR%%/plugins/AjaxEditing
+@dirrm %%WWWDIR%%/plugins
+@dirrm %%WWWDIR%%/lang
+@dirrmtry %%WWWDIR%%