aboutsummaryrefslogtreecommitdiff
path: root/www/ljpms/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2005-06-18 18:21:52 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2005-06-18 18:21:52 +0000
commit03ff430e8ff2f45f7bf10dc7cf72e7e0efd6c6ff (patch)
tree3e3070f768241878fa3a1661a36bbae42f4fc58a /www/ljpms/Makefile
parent445832b421693544b0900dbb2add247e7b700e05 (diff)
utility for batch modification of LJ permissions or LJ restoring
Notes
Notes: svn path=/head/; revision=137691
Diffstat (limited to 'www/ljpms/Makefile')
-rw-r--r--www/ljpms/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/ljpms/Makefile b/www/ljpms/Makefile
new file mode 100644
index 000000000000..4c216744447a
--- /dev/null
+++ b/www/ljpms/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ljpms
+# Date created: 12 Aug 2004
+# Whom: ache
+#
+# $FreeBSD$
+#
+
+PORTNAME= ljpms
+PORTVERSION= 1.2
+CATEGORIES= www perl5
+MASTER_SITES= http://ryzh.kiev.ua/ljsm/
+DISTFILES= ljpms-1_2.zip
+
+MAINTAINER= ache@freebsd.org
+COMMENT= Livejournal.com postings mass-restore and permissions utility
+
+RUN_DEPENDS= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+
+PLIST_FILES= bin/ljpms
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+EXTRACT_BEFORE_ARGS= -qoaa
+
+do-configure:
+ @${REINPLACE_CMD} -e 's|^#!perl|#!${PERL}|' ${WRKSRC}/ljpms.pl
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ljpms.pl ${PREFIX}/bin/ljpms
+
+.include <bsd.port.mk>