aboutsummaryrefslogtreecommitdiff
path: root/www/luakit
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-06-01 20:57:13 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-06-01 20:57:13 +0000
commitd272cf2c439fbbcd623ee3cc1e2e3d3c714fd6c4 (patch)
tree0a4c722a8bf6b2744ccaa9974158a16cd3f28c83 /www/luakit
parent4118930a6e3746693c01bcd084ec6d335e8662c6 (diff)
downloadports-d272cf2c439fbbcd623ee3cc1e2e3d3c714fd6c4.tar.gz
ports-d272cf2c439fbbcd623ee3cc1e2e3d3c714fd6c4.zip
Notes
Diffstat (limited to 'www/luakit')
-rw-r--r--www/luakit/Makefile17
-rw-r--r--www/luakit/pkg-plist2
2 files changed, 8 insertions, 11 deletions
diff --git a/www/luakit/Makefile b/www/luakit/Makefile
index 6071e999719a..e7e4dbd777c2 100644
--- a/www/luakit/Makefile
+++ b/www/luakit/Makefile
@@ -12,10 +12,10 @@ COMMENT= Fast, small, webkit based browser framework extensible by Lua
LICENSE= GPLv3
BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
-LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- sqlite3:${PORTSDIR}/databases/sqlite3 \
- webkitgtk-1:${PORTSDIR}/www/webkit-gtk2 \
- unique-1:${PORTSDIR}/x11-toolkits/unique
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
+ libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2 \
+ libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
RUN_DEPENDS= ${LUA_PKGNAMEPREFIX}luafilesystem>=0:${PORTSDIR}/devel/luafilesystem
USE_GITHUB= yes
@@ -24,16 +24,13 @@ GH_PROGECT= ${PORTNAME}
GH_TAGNAME= ${PORTVERSION:C/r/-r/}
GH_COMMIT= 0d5f4ab
-USES= pkgconfig gmake lua:51
+USES= desktop-file-utils gmake lua:51 pkgconfig
USE_GNOME= glib20 gtk20
MAKE_ARGS+= USE_UNIQUE=1 NO_JAVASCRIPTCORE=1
-MAN1= luakit.1
-
OPTIONS_DEFINE= LUAJIT
LUAJIT_DESC= Use the Just-In-Time compiler for lua
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
@@ -41,7 +38,7 @@ BROKEN= Does not install on sparc64
.endif
.if ${PORT_OPTIONS:MLUAJIT}
-LIB_DEPENDS+= luajit:${PORTSDIR}/lang/luajit
+LIB_DEPENDS+= libluajit-5.1.so:${PORTSDIR}/lang/luajit
MAKE_ARGS+= USE_LUAJIT=1
.else
MAKE_ARGS+= USE_LUAJIT=0
@@ -56,7 +53,7 @@ post-patch:
's|share/man|man| ; s|luakit/docs|doc/luakit| ; \
/MANPREFIX */s|?=|=|' \
${WRKSRC}/config.mk
- @${REINPLACE_CMD} -e 's|bin/env lua|&-${LUA_VER}|' \
+ @${REINPLACE_CMD} -e 's|bin/env lua|&${LUA_VER_STR}|' \
${WRKSRC}/build-utils/gentokens.lua
.include <bsd.port.mk>
diff --git a/www/luakit/pkg-plist b/www/luakit/pkg-plist
index 21106d0f3046..7295b6972f0f 100644
--- a/www/luakit/pkg-plist
+++ b/www/luakit/pkg-plist
@@ -6,6 +6,7 @@ etc/xdg/luakit/rc.lua
etc/xdg/luakit/theme.lua
etc/xdg/luakit/webview.lua
etc/xdg/luakit/window.lua
+man/man1/luakit.1.gz
share/applications/luakit.desktop
share/doc/luakit/README.md
share/doc/luakit/AUTHORS
@@ -59,4 +60,3 @@ share/pixmaps/luakit.png
@dirrm share/luakit
@dirrm share/doc/luakit
@dirrmtry etc/xdg/luakit
-@dirrmtry etc/xdg