aboutsummaryrefslogtreecommitdiff
path: root/www/lynx
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-06-20 07:12:22 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-06-20 07:12:22 +0000
commitf022b9aa035a0d48b37eaac2f476007bf04b7f3b (patch)
treee2c07c4419243bfa420361f13cd902df55f2e9b9 /www/lynx
parenteee71f84e6214ffbdbbb8e10f773b7cc4842d209 (diff)
downloadports-f022b9aa035a0d48b37eaac2f476007bf04b7f3b.tar.gz
ports-f022b9aa035a0d48b37eaac2f476007bf04b7f3b.zip
Notes
Diffstat (limited to 'www/lynx')
-rw-r--r--www/lynx/Makefile49
-rw-r--r--www/lynx/pkg-plist8
2 files changed, 18 insertions, 39 deletions
diff --git a/www/lynx/Makefile b/www/lynx/Makefile
index 42732ef832fe..68d829e489c9 100644
--- a/www/lynx/Makefile
+++ b/www/lynx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lynx
PORTVERSION= 2.8.7.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= http://lynx.isc.org/current/
@@ -13,7 +14,7 @@ COMMENT= Non-graphical, text-based World-Wide Web client
CONFLICTS= lynx-2.8.[8-9]*
-USE_BZIP2= yes
+USES= tar:bzip2
USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}2-8-7
GNU_CONFIGURE= yes
@@ -24,44 +25,28 @@ CONFIGURE_ARGS+=--with-zlib --libdir="${L_LIB}" \
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= DEFAULT_COLORS IPV6 NLS SSL
+OPTIONS_DEFINE= DEFAULT_COLORS IPV6 NLS SSL DOCS
OPTIONS_DEFAULT= SSL
DEFAULT_COLORS_DESC= Colors support
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+NLS_USES= gettext iconv
+NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG}
-.if empty(PORT_OPTIONS:MNLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS='@comment '
-.else
-USES+= gettext iconv
-CONFIGURE_ARGS+=--enable-nls ${ICONV_CONFIGURE_ARG}
-PLIST_SUB+= NLS=''
-.endif
+IPV6_CONFIGURE_ENABLE= ipv6
-.if ${PORT_OPTIONS:MIPV6} && !defined(NO_INET6)
-CONFIGURE_ARGS+=--enable-ipv6
-.else
-CONFIGURE_ARGS+=--disable-ipv6
-.endif
+DEFAULT_COLORS_CONFIGURE_ENABLE= default-colors
-.if ${PORT_OPTIONS:MSSL}
-CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
-.endif
+DOCS_CONFIGURE_ENABLE= local-docs
+DOCS_INSTALL_TARGET= install-full
+DOCS_MAKE_ARGS= helpdir=${L_HELP} docdir=${DOCSDIR}
+L_HELP= ${PREFIX}/share/lynx_help
-.if ${PORT_OPTIONS:MDEFAULT_COLORS}
-CONFIGURE_ARGS+=--enable-default-colors
-.endif
+.include <bsd.port.options.mk>
-.if empty(PORT_OPTIONS:MDOCS)
-CONFIGURE_ARGS+=--disable-local-docs
-INSTALL_TARGET= install
-DOCSDIR=
-L_HELP=
-.else
-INSTALL_TARGET= install-full
-L_HELP= ${PREFIX}/share/lynx_help
-MAKE_ARGS= helpdir=${L_HELP} docdir=${DOCSDIR}
+.if ${PORT_OPTIONS:MSSL}
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.endif
MAKEFILE= makefile
@@ -71,10 +56,8 @@ L_LIB= ${PREFIX}/etc
SUB_FILES= pkg-message
post-install:
-.if ${PORT_OPTIONS:MDOCS}
# Fix some stage symlinks
${LN} -sf ${DOCSDIR}/COPYHEADER ${STAGEDIR}${L_HELP}
${LN} -sf ${DOCSDIR}/COPYING ${STAGEDIR}${L_HELP}
-.endif
.include <bsd.port.mk>
diff --git a/www/lynx/pkg-plist b/www/lynx/pkg-plist
index 6f77249532a6..ea594b688f7d 100644
--- a/www/lynx/pkg-plist
+++ b/www/lynx/pkg-plist
@@ -1,10 +1,6 @@
bin/lynx
-@unexec if cmp -s %D/etc/lynx.cfg %D/etc/lynx.cfg.sample; then rm -f %D/etc/lynx.cfg; fi
-etc/lynx.cfg.sample
-@exec if [ ! -f %B/lynx.cfg ]; then cp -p %D/%F %B/lynx.cfg; fi
-@unexec if cmp -s %D/etc/lynx.lss %D/etc/lynx.lss.sample; then rm -f %D/etc/lynx.lss; fi
-etc/lynx.lss.sample
-@exec if [ ! -f %B/lynx.lss ]; then cp -p %D/%F %B/lynx.lss; fi
+@sample etc/lynx.cfg.sample
+@sample etc/lynx.lss.sample
man/man1/lynx.1.gz
@exec mkdir -p %D/%%PORTDOCS%%/share/lynx_help
%%PORTDOCS%%%%DOCSDIR%%/CHANGES