aboutsummaryrefslogtreecommitdiff
path: root/www/magento
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-01 02:14:07 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-01 02:14:07 +0000
commita58ecb64ca397341a66c5a4493fed536e7299808 (patch)
treeb194b09941113549c56648147ededf123478065a /www/magento
parentac77c49bdc25f1802eeccf26735b5eb965dbe94e (diff)
downloadports-a58ecb64ca397341a66c5a4493fed536e7299808.tar.gz
ports-a58ecb64ca397341a66c5a4493fed536e7299808.zip
Notes
Diffstat (limited to 'www/magento')
-rw-r--r--www/magento/Makefile46
-rw-r--r--www/magento/distinfo3
-rw-r--r--www/magento/files/pkg-message.in27
-rw-r--r--www/magento/pkg-descr8
4 files changed, 84 insertions, 0 deletions
diff --git a/www/magento/Makefile b/www/magento/Makefile
new file mode 100644
index 000000000000..d0b5e0b9860b
--- /dev/null
+++ b/www/magento/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: magento
+# Date created: 1st March, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= magento
+PORTVERSION= 1.4.0.1
+CATEGORIES= www finance
+MASTER_SITES= LOCAL/wen
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= A feature-rich eCommerce platform
+
+USE_BZIP2= yes
+USE_PHP= pdo_mysql hash gd iconv curl dom soap simplexml mcrypt mysql
+WRKSRC= ${WRKDIR}/magento
+
+.include <bsd.port.pre.mk>
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MAGENTODIR=${MAGENTODIR}
+
+MAGENTODIR?= www/magento
+
+pre-install:
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MAGENTODIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MAGENTODIR}?g" >> ${PLIST}
+ @${ECHO} @dirrmtry ${MAGENTODIR} >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${PREFIX}/${MAGENTODIR}
+
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MAGENTODIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MAGENTODIR}' \
+ >> ${TMPPLIST}
+ ${CHMOD} -R 755 ${PREFIX}/${MAGENTODIR}
+ @${ECHO_CMD} '@exec ${CHMOD} -R 755 ${PREFIX}/${MAGENTODIR}' >> ${TMPPLIST}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/magento/distinfo b/www/magento/distinfo
new file mode 100644
index 000000000000..e1a4f52c4b3d
--- /dev/null
+++ b/www/magento/distinfo
@@ -0,0 +1,3 @@
+MD5 (magento-1.4.0.1.tar.bz2) = c8b8b73ca0979d84dc70987b719ef7dd
+SHA256 (magento-1.4.0.1.tar.bz2) = afb9f1b84cea4816b5d4cc7a5fb2fd88c6866d6e5c52f880c70bcb566df62584
+SIZE (magento-1.4.0.1.tar.bz2) = 9714321
diff --git a/www/magento/files/pkg-message.in b/www/magento/files/pkg-message.in
new file mode 100644
index 000000000000..71a023c2152c
--- /dev/null
+++ b/www/magento/files/pkg-message.in
@@ -0,0 +1,27 @@
+POST-INSTALL CONFIGURATION FOR MOODLE
+=====================================
+
+1) Create a MySQL user and a database for Magento to store all
+ its tables in (or choose an existing database).
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ ### Add the AcceptPathInfo directive only for Apache 2.0.30 or later.
+ Alias /magento %%PREFIX%%/%%MAGENTODIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MAGENTODIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+
+3) Visit your Magento site with a browser (i.e.,
+ http://your.server.com/magento/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://www.magentocommerce.com/install
diff --git a/www/magento/pkg-descr b/www/magento/pkg-descr
new file mode 100644
index 000000000000..c7334131c1fb
--- /dev/null
+++ b/www/magento/pkg-descr
@@ -0,0 +1,8 @@
+Magento is a feature-rich eCommerce platform built on open-source technology
+that provides online merchants with unprecedented flexibility and control over
+the look, content and functionality of their eCommerce store. Magento's
+intuitive administration interface features powerful marketing, search engine
+optimization and catalog-management tools to give merchants the power to create
+sites that are tailored to their unique business needs.
+
+WWW: http://www.magentocommerce.com/