aboutsummaryrefslogtreecommitdiff
path: root/www/mathopd/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2003-12-05 00:02:41 +0000
committerAnton Berezin <tobez@FreeBSD.org>2003-12-05 00:02:41 +0000
commit44f8659a1b2f46e15e1a993d544792bdb541f5b0 (patch)
tree90c20fc0bda1a8a3cef13e026dfa57b2f080910a /www/mathopd/Makefile
parentbe1398822586f02e2ca716da5a4942e82efca7f5 (diff)
downloadports-44f8659a1b2f46e15e1a993d544792bdb541f5b0.tar.gz
ports-44f8659a1b2f46e15e1a993d544792bdb541f5b0.zip
Notes
Diffstat (limited to 'www/mathopd/Makefile')
-rw-r--r--www/mathopd/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/www/mathopd/Makefile b/www/mathopd/Makefile
index 4a90958f4a9f..e71cf4f8c220 100644
--- a/www/mathopd/Makefile
+++ b/www/mathopd/Makefile
@@ -6,27 +6,27 @@
#
PORTNAME= mathopd
-PORTVERSION= 1.3p7
+PORTVERSION= 1.4p2
CATEGORIES= www
MASTER_SITES= http://www.mathopd.org/dist/ \
- ftp://ftp.prima.eu.org/pub/mirrored_files/mathop.diva.nl/ \
http://www.tobez.org/download/port-mirrors/www/mathopd/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/pl/}
MAINTAINER= tobez@FreeBSD.org
COMMENT= A very small, yet very fast HTTP server
+DOCS= CHANGES cgi.txt config.txt processing.txt running.txt sample.cfg syntax.txt
+
post-install:
- @${INSTALL_DATA} ${FILESDIR}/mathopd.conf.sample ${PREFIX}/etc
+ @${INSTALL_DATA} ${WRKSRC}/doc/sample.cfg ${PREFIX}/etc/mathopd.conf.sample
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/mathopd
- @${INSTALL_DATA} ${WRKSRC}/CHANGES ${PREFIX}/share/doc/mathopd
@${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/mathopd
@${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/mathopd
+.for df in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${df} ${PREFIX}/share/doc/mathopd
+.endfor
.endif
- @if [ ! -f ${PREFIX}/etc/rc.d/mathopd.sh ]; then \
- ${INSTALL_SCRIPT} ${FILESDIR}/mathopd.sh ${PREFIX}/etc/rc.d/mathopd.sh; \
- fi
+ ${INSTALL_SCRIPT} ${FILESDIR}/mathopd.sh ${PREFIX}/etc/rc.d/mathopd.sh-dist
@${SED} -e 's,/usr/local,${PREFIX},g' ${PKGMESSAGE}
.include <bsd.port.mk>