aboutsummaryrefslogtreecommitdiff
path: root/www/mgstat/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-10-30 16:46:42 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-10-30 16:46:42 +0000
commit503ad9bd2e420dbbfaf11eec0fdd7c628b039b29 (patch)
treef7270689365e865157fa8013424ae11d200f047f /www/mgstat/Makefile
parent6b00f682106f8e40ae0fb7056cc8ef6904da1e3a (diff)
downloadports-503ad9bd2e420dbbfaf11eec0fdd7c628b039b29.tar.gz
ports-503ad9bd2e420dbbfaf11eec0fdd7c628b039b29.zip
Notes
Diffstat (limited to 'www/mgstat/Makefile')
-rw-r--r--www/mgstat/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/www/mgstat/Makefile b/www/mgstat/Makefile
index 6fea3efd7233..02d114a9b3cb 100644
--- a/www/mgstat/Makefile
+++ b/www/mgstat/Makefile
@@ -18,20 +18,19 @@ LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
GNU_CONFIGURE= yes
-MGDOCDIR= ${PREFIX}/share/doc/mgstat
+PORTDOCS= Copyright README USAGE
+PLIST_FILES= bin/mgstat
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
+USE_GCC= 3.3
.endif
post-install:
.if !defined(NOPORTDOCS)
- @if ! [ -d ${MGDOCDIR} ]; then ${MKDIR} ${MGDOCDIR}; fi
- ${INSTALL_DATA} ${WRKSRC}/Copyright ${MGDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${MGDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/USAGE ${MGDOCDIR}
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>