aboutsummaryrefslogtreecommitdiff
path: root/www/middleman
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-04 22:55:38 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-04 22:55:38 +0000
commitf9ad0cfce376e91666abe300e9513061fe3a7b4a (patch)
treeb37eb3cc6dc83210f5563a487b2b412cf2cbfe6c /www/middleman
parentbf7b9a0c0e9d1a554dfe6cc16566a0573f138b0f (diff)
downloadports-f9ad0cfce376e91666abe300e9513061fe3a7b4a.tar.gz
ports-f9ad0cfce376e91666abe300e9513061fe3a7b4a.zip
Notes
Diffstat (limited to 'www/middleman')
-rw-r--r--www/middleman/Makefile16
-rw-r--r--www/middleman/files/patch-include-macros.h26
2 files changed, 31 insertions, 11 deletions
diff --git a/www/middleman/Makefile b/www/middleman/Makefile
index 77f93b9e18b7..5013d7cda030 100644
--- a/www/middleman/Makefile
+++ b/www/middleman/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: middleman
-# Date created: Sun Apr 27 15:48:16 CEST 2003
-# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+# New ports collection makefile for: middleman
+# Date created: Sun Apr 27 15:48:16 CEST 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
#
# $FreeBSD$
#
@@ -40,12 +40,6 @@ CONFIGURE_ARGS+= --enable-mtime
MMAN_CACHE= /var/cache/mman
PLIST_SUB+= MMAN_CACHE=${MMAN_CACHE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/bin/mman|${PREFIX}/bin/mman|g ; \
@@ -62,9 +56,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/scripts/mman.init \
${PREFIX}/etc/rc.d/mman.sh.sample
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/scripts/filter.pl ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/middleman/files/patch-include-macros.h b/www/middleman/files/patch-include-macros.h
new file mode 100644
index 000000000000..635d366909dd
--- /dev/null
+++ b/www/middleman/files/patch-include-macros.h
@@ -0,0 +1,26 @@
+--- include/macros.h.orig Sat Jul 19 05:53:50 2003
++++ include/macros.h Thu Jul 5 05:45:33 2007
+@@ -103,9 +103,10 @@
+ /*
+ this macro will shift a node in a linked list up or down one
+ */
+-#define SHIFTNODE(t, x, a, d) { \
++#define SHIFTNODE(t, _x, a, d) { \
+ do { \
+ t tmp_node = NULL; \
++ t x = _x; \
+ if (d == UP && a != (x)) { \
+ if ((x) == a->prev) (x) = a; \
+ if (a->prev->prev != NULL) a->prev->prev->next = a; \
+@@ -131,9 +132,10 @@
+ /*
+ this macro moves a list node to top or bottom of list
+ */
+-#define SETNODE(t, x, a, d) { \
++#define SETNODE(t, _x, a, d) { \
+ do { \
+ t tmp_node = NULL; \
++ t x = _x; \
+ if (d == TOP && a != (x)) { \
+ if (a->next != NULL) a->next->prev = a->prev; \
+ a->prev->next = a->next; \