aboutsummaryrefslogtreecommitdiff
path: root/www/middleman
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-04 12:29:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-04 12:29:06 +0000
commit5bce3408bc51e725904a08ab425eaeacebde08f9 (patch)
tree096d7e824831011d2af2d9953ff156df6696e7e2 /www/middleman
parentfca15c081ccc4af2ea2f99ea823a5634e339b826 (diff)
downloadports-5bce3408bc51e725904a08ab425eaeacebde08f9.tar.gz
ports-5bce3408bc51e725904a08ab425eaeacebde08f9.zip
Notes
Diffstat (limited to 'www/middleman')
-rw-r--r--www/middleman/Makefile8
-rw-r--r--www/middleman/distinfo2
-rw-r--r--www/middleman/files/patch-pcre-internal.h12
3 files changed, 17 insertions, 5 deletions
diff --git a/www/middleman/Makefile b/www/middleman/Makefile
index 55f85a4de359..3808d9722758 100644
--- a/www/middleman/Makefile
+++ b/www/middleman/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= middleman
-PORTVERSION= 1.8.3
+PORTVERSION= 1.9
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= middle-man
@@ -19,6 +19,9 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
MAN8= mman.8
.if defined(WITH_SYSLOG)
@@ -38,9 +41,6 @@ PLIST_SUB+= MMAN_CACHE=${MMAN_CACHE}
post-patch:
@${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
's|/usr/bin/mman|${PREFIX}/bin/mman|g ; \
s|/etc/mman/config.xml|${PREFIX}/etc/mman.xml|g' \
${WRKSRC}/scripts/mman.init \
diff --git a/www/middleman/distinfo b/www/middleman/distinfo
index 235483bc3f03..6f5d1e73f747 100644
--- a/www/middleman/distinfo
+++ b/www/middleman/distinfo
@@ -1 +1 @@
-MD5 (middleman-1.8.3.tar.gz) = 3628e25c4eda47b81ee2cad8554c1df9
+MD5 (middleman-1.9.tar.gz) = 235302e462d9dfe833e9484d445089bf
diff --git a/www/middleman/files/patch-pcre-internal.h b/www/middleman/files/patch-pcre-internal.h
new file mode 100644
index 000000000000..cee3c3cf4af4
--- /dev/null
+++ b/www/middleman/files/patch-pcre-internal.h
@@ -0,0 +1,12 @@
+--- pcre/internal.h.orig Thu Sep 18 21:59:10 2003
++++ pcre/internal.h Thu Sep 18 21:59:30 2003
+@@ -38,6 +38,9 @@
+ /* Get the definitions provided by running "configure" */
+
+ #include "config.h"
++#include <ctype.h>
++#include <stdlib.h>
++#include <string.h>
+
+ /* To cope with SunOS4 and other systems that lack memmove() but have bcopy(),
+ define a macro for memmove() if HAVE_MEMMOVE is false, provided that HAVE_BCOPY