aboutsummaryrefslogtreecommitdiff
path: root/www/midori/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2008-11-24 03:19:40 +0000
committerMichael Johnson <ahze@FreeBSD.org>2008-11-24 03:19:40 +0000
commit68a978ac81ffcf4b2c29260a11fe7dd927dfbc11 (patch)
tree320d4314b06569f1c0ae462c29ec411017fbc99b /www/midori/Makefile
parentd887c438c8ef3a49b954f911846884577e8c8c06 (diff)
Notes
Diffstat (limited to 'www/midori/Makefile')
-rw-r--r--www/midori/Makefile28
1 files changed, 20 insertions, 8 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 51a69eb48246..a4a52945dd7d 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -6,23 +6,35 @@
# $MCom: ports/www/midori/Makefile,v 1.3 2008/03/21 18:31:39 ahze Exp $
PORTNAME= midori
-PORTVERSION= 0.0.18
-PORTREVISION= 2
+PORTVERSION= 0.1.0
CATEGORIES= www
-MASTER_SITES= http://software.twotoasts.de/media/${PORTNAME}/
+MASTER_SITES= http://goodies.xfce.org/releases/${PORTNAME}/
MAINTAINER= ahze@FreeBSD.org
COMMENT= Lightweight web browser using WebKit browser engine
-LIB_DEPENDS= WebKitGtk.1:${PORTSDIR}/www/webkit-gtk2 \
- sexy.2:${PORTSDIR}/x11-toolkits/libsexy
+LIB_DEPENDS= WebKitGtk.1:${PORTSDIR}/www/webkit-gtk2
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
+ rsvg-convert:${PORTSDIR}/graphics/librsvg2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/WebKit/webkit -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--disable-unique \
+ --disable-gio \
+ --disable-sqlite
+
+HAS_CONFIGURE= yes
USE_GMAKE= yes
+USE_BZIP2= yes
+USE_GNOME= glib20 gtk20 intltool libxml2 pkgconfig
+INSTALLS_ICONS= yes
-pre-install:
- ${CHMOD} +x ${WRKSRC}/install-sh
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
.include <bsd.port.mk>