aboutsummaryrefslogtreecommitdiff
path: root/www/midori
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-01-16 05:27:36 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-01-16 05:27:36 +0000
commite0d7d0390a53e58fcd7cb21e0147068a85cc56f8 (patch)
treed90c9794c6d2f7f53c2744434c83e7a45bf9beac /www/midori
parenta381de43fbe5cbe39d80b5860e02361dde0666c6 (diff)
downloadports-e0d7d0390a53e58fcd7cb21e0147068a85cc56f8.tar.gz
ports-e0d7d0390a53e58fcd7cb21e0147068a85cc56f8.zip
Notes
Diffstat (limited to 'www/midori')
-rw-r--r--www/midori/Makefile9
-rw-r--r--www/midori/distinfo4
-rw-r--r--www/midori/files/patch-CMakeLists.txt10
-rw-r--r--www/midori/files/patch-extensions__CMakeLists.txt10
-rw-r--r--www/midori/pkg-plist8
5 files changed, 27 insertions, 14 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 3d4278a727b7..3b84250f780a 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= midori
-PORTVERSION= 0.5.6
-PORTREVISION= 1
+PORTVERSION= 0.5.7
CATEGORIES= www xfce
MASTER_SITES= http://www.midori-browser.org/downloads/
DISTNAME= ${PORTNAME}_${PORTVERSION}_all_
@@ -12,7 +11,8 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Lightweight web browser using WebKit browser engine
-LICENSE= LGPL21
+LICENSE= LGPL21 MIT
+LICENSE_COMB= multi
BUILD_DEPENDS= rsvg-convert:${PORTSDIR}/graphics/librsvg2 \
valac:${PORTSDIR}/lang/vala
@@ -81,8 +81,9 @@ CMAKE_ARGS+= -DUSE_ZEITGEIST:BOOL=OFF
post-patch:
# Avoid errors with CMake
+ @${RM} ${WRKSRC}/*.orig
.for dir in config extensions
- @cd ${WRKSRC} && ${RM} ${dir}/*.orig
+ @${RM} ${WRKSRC}/${dir}/*.orig
.endfor
.include <bsd.port.mk>
diff --git a/www/midori/distinfo b/www/midori/distinfo
index 4f01c5346b8a..b1862f9b36d7 100644
--- a/www/midori/distinfo
+++ b/www/midori/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/midori_0.5.6_all_.tar.bz2) = c5be1b5d9933776f09c5cab7945a073a820d65555e51fda9ff55fd063843f24a
-SIZE (xfce4/midori_0.5.6_all_.tar.bz2) = 1194529
+SHA256 (xfce4/midori_0.5.7_all_.tar.bz2) = 2875bb2aa8a8a0cce342178f04700d4ebccd13bf1b2ad4cb3ba9fec7e2bd0b4d
+SIZE (xfce4/midori_0.5.7_all_.tar.bz2) = 1191260
diff --git a/www/midori/files/patch-CMakeLists.txt b/www/midori/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..ee8d46a82733
--- /dev/null
+++ b/www/midori/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- ./CMakeLists.txt.orig 2014-01-15 20:43:34.000000000 +0000
++++ ./CMakeLists.txt 2014-01-15 22:50:54.000000000 +0000
+@@ -100,6 +100,7 @@
+ string(FIND ${CMAKE_SYSTEM_NAME} "BSD" BEGIN)
+ if (${BEGIN} GREATER 0)
+ string(SUBSTRING ${CMAKE_SYSTEM_NAME} ${BEGIN} 3 BSD)
++ set(BSD 1 CACHE INTERNAL BOOL FORCE)
+ else()
+ set(BSD 0)
+ endif()
diff --git a/www/midori/files/patch-extensions__CMakeLists.txt b/www/midori/files/patch-extensions__CMakeLists.txt
index 9aab80735d8f..59d061be1d55 100644
--- a/www/midori/files/patch-extensions__CMakeLists.txt
+++ b/www/midori/files/patch-extensions__CMakeLists.txt
@@ -1,13 +1,9 @@
---- ./extensions/CMakeLists.txt.orig 2013-11-20 01:26:52.000000000 +0000
-+++ ./extensions/CMakeLists.txt 2014-01-02 16:00:24.000000000 +0000
-@@ -24,6 +24,15 @@
+--- ./extensions/CMakeLists.txt.orig 2014-01-15 20:43:34.000000000 +0000
++++ ./extensions/CMakeLists.txt 2014-01-15 22:52:29.000000000 +0000
+@@ -24,6 +24,11 @@
"nsplugin-manager.vala"
)
endif ()
-+string(FIND ${CMAKE_SYSTEM_NAME} "BSD" BEGIN)
-+if (${BEGIN} GREATER 0)
-+ string(SUBSTRING ${CMAKE_SYSTEM_NAME} ${BEGIN} 3 BSD)
-+endif ()
+if (BSD)
+ list(REMOVE_ITEM EXTENSIONS
+ "devpet.vala"
diff --git a/www/midori/pkg-plist b/www/midori/pkg-plist
index 51d2b2a5c6b7..28630e413275 100644
--- a/www/midori/pkg-plist
+++ b/www/midori/pkg-plist
@@ -14,6 +14,7 @@ lib/midori/libcopy-tabs.so
lib/midori/libdelayed-load.so
lib/midori/libexternal-download-manager.so
lib/midori/libfeed-panel.so
+lib/midori/libflummi.so
lib/midori/libformhistory.so
lib/midori/libhistory-list.so
lib/midori/libmouse-gestures.so
@@ -49,7 +50,6 @@ share/applications/midori.desktop
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-gtk3-compat.html
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-katze-arrayaction.html
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-katze-http-auth.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-katze-throbber.html
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-katze-utils.html
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze.devhelp2
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/left.png
@@ -161,17 +161,23 @@ share/locale/zh_TW/LC_MESSAGES/midori.mo
%%DATADIR%%/res/bookmarks/Import_old_db_bookmarks.sql
%%DATADIR%%/res/close.png
%%DATADIR%%/res/error.html
+%%DATADIR%%/res/flummi/Create.sql
%%DATADIR%%/res/forms/Create.sql
%%DATADIR%%/res/gtk3.css
%%DATADIR%%/res/history/Create.sql
%%DATADIR%%/res/history/Day.sql
%%DATADIR%%/res/logo-shade.png
+%%DATADIR%%/res/nojs/nojs-statusicon-allowed.png
+%%DATADIR%%/res/nojs/nojs-statusicon-denied.png
+%%DATADIR%%/res/nojs/nojs-statusicon-mixed.png
%%DATADIR%%/res/speeddial-head.html
%%DATADIR%%/res/tabby/Create.sql
%%DATADIR%%/res/tabby/Update1.sql
@dirrm %%DATADIR%%/res/tabby
+@dirrm %%DATADIR%%/res/nojs
@dirrm %%DATADIR%%/res/history
@dirrm %%DATADIR%%/res/forms
+@dirrm %%DATADIR%%/res/flummi
@dirrm %%DATADIR%%/res/bookmarks
@dirrm %%DATADIR%%/res
@dirrm %%DATADIR%%