aboutsummaryrefslogtreecommitdiff
path: root/www/mnogosearch/files
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2004-05-21 09:12:33 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2004-05-21 09:12:33 +0000
commit95bc3fbcc47f2ae6a4e0f899bb0e69fca6291a2b (patch)
tree17ec8070ba7a1e63f1fbf6d1c12aa78136f240bb /www/mnogosearch/files
parent0dc2e87f9c685ba5b10d04f6698c85c8eb491159 (diff)
downloadports-95bc3fbcc47f2ae6a4e0f899bb0e69fca6291a2b.tar.gz
ports-95bc3fbcc47f2ae6a4e0f899bb0e69fca6291a2b.zip
Notes
Diffstat (limited to 'www/mnogosearch/files')
-rw-r--r--www/mnogosearch/files/patch-ab31
-rw-r--r--www/mnogosearch/files/patch-ac11
-rw-r--r--www/mnogosearch/files/patch-ad18
3 files changed, 23 insertions, 37 deletions
diff --git a/www/mnogosearch/files/patch-ab b/www/mnogosearch/files/patch-ab
index 6969705dd615..83f008648de7 100644
--- a/www/mnogosearch/files/patch-ab
+++ b/www/mnogosearch/files/patch-ab
@@ -1,25 +1,22 @@
-
-$FreeBSD$
-
---- src/Makefile.in.orig Thu Jun 27 13:20:28 2002
-+++ src/Makefile.in Tue Jul 9 11:20:40 2002
-@@ -131,7 +131,7 @@
- libudmsearch_la_SOURCES = indexer.c parseurl.c charset.c parser.c sql.c spell.c log.c proto.c udmutils.c robots.c hrefs.c mutex.c conf.c files.c crc32.c parsedate.c ftp.c socket.c host.c udmxmalloc.c http.c id3.c cache.c boolean.c searchtool.c server.c alias.c filter.c env.c mimetype.c agent.c word.c parsehtml.c stopwords.c execget.c crossword.c
+--- src/Makefile.in.orig Tue Jun 17 13:35:12 2003
++++ src/Makefile.in Fri May 21 12:22:36 2004
+@@ -145,7 +145,7 @@
+ agent.c word.c parsehtml.c stopwords.c execget.c crossword.c
-libudmsearch_la_LDFLAGS = -release 3.1
+libudmsearch_la_LDFLAGS = -version-info 1:0:0
- include_HEADERS = ../include/udm_charset.h ../include/udm_common.h ../include/udm_conf.h ../include/udm_config.h ../include/udm_db.h ../include/udm_hrefs.h ../include/udm_indexer.h ../include/udm_log.h ../include/udm_parseurl.h ../include/udm_spell.h ../include/udm_mutex.h ../include/udm_utils.h ../include/udmsearch.h ../include/udm_search_tl.h ../include/udm_ftp.h ../include/udm_socket.h ../include/udm_host.h ../include/udm_xmalloc.h ../include/udm_id3.h ../include/udm_http.h ../include/udm_crc32.h ../include/udm_http.h ../include/udm_cache.h ../include/udm_boolean.h ../include/udm_server.h ../include/udm_searchtool.h ../include/udm_alias.h ../include/udm_filter.h ../include/udm_env.h ../include/udm_mimetype.h ../include/udm_agent.h ../include/udm_word.h ../include/udm_parsehtml.h ../include/udm_stopwords.h ../include/udm_parser.h ../include/udm_proto.h ../include/udm_robots.h ../include/udm_signals.h ../include/udm_execget.h ../include/udm_services.h
-
-@@ -275,8 +275,8 @@
- $(mkinstalldirs) $(DESTDIR)$(bindir)
- @list='$(bin_PROGRAMS)'; for p in $$list; do \
- if test -f $$p; then \
-- echo " $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
-- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
-+ echo " $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(prefix)/share/mnogosearch/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
-+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(prefix)/share/mnogosearch/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
+ INCLUDES = -I../include \
+ @VIRT_INCLUDE@ \
+@@ -304,8 +304,8 @@
+ || test -f $$p1 \
+ ; then \
+ f=`echo $$p1|sed '$(transform);s/$$/$(EXEEXT)/'`; \
+- echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/$$f"; \
+- $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/$$f; \
++ echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(prefix)/share/mnogosearch/$$f"; \
++ $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(prefix)/share/mnogosearch/$$f; \
else :; fi; \
done
diff --git a/www/mnogosearch/files/patch-ac b/www/mnogosearch/files/patch-ac
deleted file mode 100644
index 65c6f2ac627d..000000000000
--- a/www/mnogosearch/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/search.c.orig Tue Jun 26 12:55:17 2001
-+++ src/search.c Wed May 15 11:29:07 2002
-@@ -1246,7 +1246,7 @@
- int i;
- time_t tclock;
- tclock=time(0);
-- srand((unsigned)tclock);
-+ srand((unsigned)(tclock^(getpid()<<16)));
- for(i=0;i<MAXRANDOM;i++)
- Randoms[i]=0;
- }
diff --git a/www/mnogosearch/files/patch-ad b/www/mnogosearch/files/patch-ad
index e798af64758c..3cbbe9361454 100644
--- a/www/mnogosearch/files/patch-ad
+++ b/www/mnogosearch/files/patch-ad
@@ -1,13 +1,13 @@
---- configure.bak Thu Jun 27 14:20:21 2002
-+++ configure Wed Sep 24 09:40:31 2003
-@@ -3247,8 +3247,8 @@
- EOF
+--- configure.orig Tue Jun 17 13:35:22 2003
++++ configure Fri May 21 12:30:40 2004
+@@ -5826,8 +5826,8 @@
- echo "$ac_t""enabled" 1>&6
+ echo "$as_me:$LINENO: result: enabled" >&5
+ echo "${ECHO_T}enabled" >&6
- PTHREAD_CFLAGS="-pthread"
- PTHREAD_LFLAGS="-pthread"
-+# PTHREAD_CFLAGS="-pthread"
-+# PTHREAD_LFLAGS="-pthread"
++# PTHREAD_CFLAGS="-pthread"
++# PTHREAD_LFLAGS="-pthread"
else
- echo "$ac_t""disabled" 1>&6
- fi
+ echo "$as_me:$LINENO: result: disabled" >&5
+ echo "${ECHO_T}disabled" >&6