aboutsummaryrefslogtreecommitdiff
path: root/www/mnogosearch
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2004-06-14 03:21:58 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2004-06-14 03:21:58 +0000
commit300967d7b79e1d24080ada5ebfef6d3049d95e5a (patch)
treef3a2dd08d2d3202a9ca6e7e48cae79a049d3dde8 /www/mnogosearch
parent8c4e950162e5616c57b81c31f01549f6cc63af60 (diff)
downloadports-300967d7b79e1d24080ada5ebfef6d3049d95e5a.tar.gz
ports-300967d7b79e1d24080ada5ebfef6d3049d95e5a.zip
Notes
Diffstat (limited to 'www/mnogosearch')
-rw-r--r--www/mnogosearch/Makefile1
-rw-r--r--www/mnogosearch/files/patch-ad50
2 files changed, 49 insertions, 2 deletions
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index be246054cb1a..8fc62a81f59e 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -20,6 +20,7 @@ MAN5= indexer.conf.5
INSTALLS_SHLIB= yes
USE_GMAKE= yes
+USE_LIBTOOL_VER=13
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+=--enable-phrase \
diff --git a/www/mnogosearch/files/patch-ad b/www/mnogosearch/files/patch-ad
index 3cbbe9361454..c81d6f29511b 100644
--- a/www/mnogosearch/files/patch-ad
+++ b/www/mnogosearch/files/patch-ad
@@ -1,6 +1,32 @@
--- configure.orig Tue Jun 17 13:35:22 2003
-+++ configure Fri May 21 12:30:40 2004
-@@ -5826,8 +5826,8 @@
++++ configure Mon Jun 14 07:09:11 2004
+@@ -3176,13 +3176,14 @@
+ fi
+ rm -f confcache
+
++lt_aux_dir=${prefix}/share/libtool13
+ # Actually configure libtool. ac_aux_dir is where install-sh is found.
+ CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
+ LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
+ LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
+ DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
+-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
+-$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $lt_target \
++${CONFIG_SHELL-/bin/sh} $lt_aux_dir/ltconfig --no-reexec \
++$libtool_flags --no-verify $lt_aux_dir/ltmain.sh $lt_target \
+ || { { echo "$as_me:$LINENO: error: libtool configure failed" >&5
+ echo "$as_me: error: libtool configure failed" >&2;}
+ { (exit 1); exit 1; }; }
+@@ -3207,7 +3208,7 @@
+
+
+ # This can be used to rebuild libtool when needed
+-LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
++LIBTOOL_DEPS="$lt_aux_dir/ltconfig $lt_aux_dir/ltmain.sh"
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -5826,8 +5827,8 @@
echo "$as_me:$LINENO: result: enabled" >&5
echo "${ECHO_T}enabled" >&6
@@ -11,3 +37,23 @@
else
echo "$as_me:$LINENO: result: disabled" >&5
echo "${ECHO_T}disabled" >&6
+@@ -7553,8 +7554,8 @@
+ LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
+ LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
+ DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
+-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
+-$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $lt_target \
++${CONFIG_SHELL-/bin/sh} $lt_aux_dir/ltconfig --no-reexec \
++$libtool_flags --no-verify $lt_aux_dir/ltmain.sh $lt_target \
+ || { { echo "$as_me:$LINENO: error: libtool configure failed" >&5
+ echo "$as_me: error: libtool configure failed" >&2;}
+ { (exit 1); exit 1; }; }
+@@ -7579,7 +7580,7 @@
+
+
+ # This can be used to rebuild libtool when needed
+-LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
++LIBTOOL_DEPS="$lt_aux_dir/ltconfig $lt_aux_dir/ltmain.sh"
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'