aboutsummaryrefslogtreecommitdiff
path: root/www/mnogosearch
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-12-26 22:46:15 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-12-26 22:46:15 +0000
commitb733da20b1ca175ab687e311e9c3cfa2593cb1ed (patch)
tree043b2d8ec7e5c3d87af7c1550d29ac73bf6aa146 /www/mnogosearch
parent0438631386c2ce8315ce4e8215fc429abb8c9da7 (diff)
downloadports-b733da20b1ca175ab687e311e9c3cfa2593cb1ed.tar.gz
ports-b733da20b1ca175ab687e311e9c3cfa2593cb1ed.zip
Notes
Diffstat (limited to 'www/mnogosearch')
-rw-r--r--www/mnogosearch/Makefile33
-rw-r--r--www/mnogosearch/distinfo6
-rw-r--r--www/mnogosearch/pkg-plist3
3 files changed, 22 insertions, 20 deletions
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index 8bc1bb9cd6fa..562c78035eb1 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mnogosearch
-PORTVERSION= 3.3.9
-PORTREVISION= 1
+PORTVERSION= 3.3.10
CATEGORIES= www databases
MASTER_SITES= http://www.mnogosearch.org/Download/
@@ -17,6 +16,16 @@ COMMENT= Full featured SQL-based hypertext search engine
MAN1= indexer.1
MAN5= indexer.conf.5
+OPTIONS= \
+ THREADS "Enable pthreads" on \
+ SSL "Enable SSL" on \
+ ASIAN "Enable asian charsets" off \
+ SYSLOG "Send logs to syslog" on \
+ PGSQL "Use PGSQL" off \
+ MSQL "Use MSQL" off \
+ MYSQL "Use MySQL" off \
+ SQLITE "Use SQLite 2.x" on
+
USE_LDCONFIG= yes
USE_GNOME= lthack
USE_GMAKE= yes
@@ -33,22 +42,12 @@ SHLIB_VER= 1
SUB_FILES+= pkg-message
-OPTIONS= \
- THREADS "Enable pthreads" on \
- SSL "Enable SSL" on \
- ASIAN "Enable asian charsets" off \
- SYSLOG "Send logs to syslog" on \
- PGSQL "Use PGSQL" off \
- MSQL "Use MSQL" off \
- MYSQL "Use MySQL" off \
- SQLITE "Use SQLite 2.x" on
+.include <bsd.port.options.mk>
-.if !defined(NO_OPENSSL)
+.if defined(WITH_SSL)
USE_OPENSSL= yes
.endif
-.include <bsd.port.pre.mk>
-
.ifdef WITHOUT_THREADS
CONFIGURE_ARGS+= --disable-pthreads
CFLAGS+= -DCONSOLE
@@ -58,7 +57,7 @@ CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}"
.endif
-.if !defined(WITHOUT_SSL) || !defined(NO_OPENSSL)
+.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.endif
@@ -110,10 +109,12 @@ post-install:
${PREFIX}/lib/libmnogosearch-${PORTVERSION:R}.so.${SHLIB_VER}
${CHMOD} 700 /var/mnogosearch/cache
${CHOWN} -R ${WWWOWN}:${WWWGRP} /var/mnogosearch
+.if !defined (NOPORTDOCS)
${MKDIR} ${DOCSDIR}/
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
.endfor
+.endif
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/samples/* ${EXAMPLESDIR}/
@@ -121,4 +122,4 @@ post-install:
@${ECHO}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/mnogosearch/distinfo b/www/mnogosearch/distinfo
index 1b849e63295b..c8eae02a92da 100644
--- a/www/mnogosearch/distinfo
+++ b/www/mnogosearch/distinfo
@@ -1,3 +1,3 @@
-MD5 (mnogosearch-3.3.9.tar.gz) = 8898bdbc2c86b7e130f9bcb551e1b0d1
-SHA256 (mnogosearch-3.3.9.tar.gz) = 2c37ea486fa348ed259c80116a6bbb460d556f309b9b36932dee2bae3404cbe3
-SIZE (mnogosearch-3.3.9.tar.gz) = 3757216
+MD5 (mnogosearch-3.3.10.tar.gz) = a03a73fd46c981505cf4c09e984b92c6
+SHA256 (mnogosearch-3.3.10.tar.gz) = b1cd578a7a22ed2660b51529728389946a456faca27fb32b6c53f52ab415cf11
+SIZE (mnogosearch-3.3.10.tar.gz) = 3870413
diff --git a/www/mnogosearch/pkg-plist b/www/mnogosearch/pkg-plist
index 42a1663c4bf2..25e86ed2d12b 100644
--- a/www/mnogosearch/pkg-plist
+++ b/www/mnogosearch/pkg-plist
@@ -307,6 +307,7 @@ sbin/indexer
%%DOCSDIR%%/msearch-cmdref-checkmp3only.html
%%DOCSDIR%%/msearch-cmdref-checkonly.html
%%DOCSDIR%%/msearch-cmdref-collectlinks.html
+%%DOCSDIR%%/msearch-cmdref-complexsynonyms.html
%%DOCSDIR%%/msearch-cmdref-crosswords.html
%%DOCSDIR%%/msearch-cmdref-customlog.html
%%DOCSDIR%%/msearch-cmdref-cvsignore.html
@@ -338,6 +339,7 @@ sbin/indexer
%%DOCSDIR%%/msearch-cmdref-htdblimit.html
%%DOCSDIR%%/msearch-cmdref-htdblist.html
%%DOCSDIR%%/msearch-cmdref-httpheader.html
+%%DOCSDIR%%/msearch-cmdref-idffactor.html
%%DOCSDIR%%/msearch-cmdref-importenv.html
%%DOCSDIR%%/msearch-cmdref-include.html
%%DOCSDIR%%/msearch-cmdref-index.html
@@ -504,4 +506,3 @@ sbin/indexer
@dirrm %%ETCDIR%%/langmap
@dirrm %%ETCDIR%%
@dirrm %%DOCSDIR%%
-