aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_cas
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-08-25 16:48:55 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-08-25 16:48:55 +0000
commitd3d2b289d4309e4aa09d33f56ac7243a9c086fb5 (patch)
treefb1489693b7bafe8ff765757b657b897b65591d2 /www/mod_auth_cas
parent8f9518e03fa54681be29d8103f5f3f283ab22cc3 (diff)
downloadports-d3d2b289d4309e4aa09d33f56ac7243a9c086fb5.tar.gz
ports-d3d2b289d4309e4aa09d33f56ac7243a9c086fb5.zip
Notes
Diffstat (limited to 'www/mod_auth_cas')
-rw-r--r--www/mod_auth_cas/Makefile17
-rw-r--r--www/mod_auth_cas/distinfo8
-rw-r--r--www/mod_auth_cas/pkg-message32
3 files changed, 48 insertions, 9 deletions
diff --git a/www/mod_auth_cas/Makefile b/www/mod_auth_cas/Makefile
index 1e99a31058d0..4c1161171dbc 100644
--- a/www/mod_auth_cas/Makefile
+++ b/www/mod_auth_cas/Makefile
@@ -6,28 +6,35 @@
#
PORTNAME= mod_auth_cas
-PORTVERSION= 1.0.8
-PORTREVISION= 1
+PORTVERSION= 1.0.9.1
CATEGORIES= www
-#MASTER_SITES= https://www.ja-sig.org/svn/cas-clients/mod_auth_cas/tags/mod_auth_cas-1.0.8/src/
+MASTER_SITES= https://source.jasig.org/cas-clients/mod_auth_cas/tags/mod_auth_cas-${PORTVERSION}/src/
# SVN tags only, *sigh*
DISTFILES= mod_auth_cas.c mod_auth_cas.h
-DIST_SUBDIR= mod_auth_cas
+DIST_SUBDIR= apache2/mod_auth_cas/${PORTVERSION}
EXTRACT_ONLY=
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache 2.x module that supports the CASv1 and CASv2 protocols
-MAKE_JOBS_SAFE= yes
+LICENSE= AL2
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+MAKE_JOBS_SAFE= yes
NO_WRKSUBDIR= yes
USE_APACHE= 22+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
+AP_LIB= ${LOCALBASE}/lib
+AP_EXTRAS= -l ssl -l curl
post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/mod_auth_cas.c ${WRKSRC}/mod_auth_cas.c
${CP} ${DISTDIR}/${DIST_SUBDIR}/mod_auth_cas.h ${WRKSRC}/mod_auth_cas.h
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/www/mod_auth_cas/distinfo b/www/mod_auth_cas/distinfo
index c0faa967290f..27e030b914bc 100644
--- a/www/mod_auth_cas/distinfo
+++ b/www/mod_auth_cas/distinfo
@@ -1,4 +1,4 @@
-SHA256 (mod_auth_cas/mod_auth_cas.c) = 0603d66013bac281067d67067a0400c00e036f63a1075ee8257afe049a70a683
-SIZE (mod_auth_cas/mod_auth_cas.c) = 67710
-SHA256 (mod_auth_cas/mod_auth_cas.h) = e0359ac88a290f9c8f9686b9d60ea61ec230f28146abf4ac6a3239feeadaad28
-SIZE (mod_auth_cas/mod_auth_cas.h) = 7409
+SHA256 (apache2/mod_auth_cas/1.0.9.1/mod_auth_cas.c) = ddff1d54d2824842b6abacc882c6105a9d006964b7e3b367c1e77c8e5b0a92c1
+SIZE (apache2/mod_auth_cas/1.0.9.1/mod_auth_cas.c) = 81903
+SHA256 (apache2/mod_auth_cas/1.0.9.1/mod_auth_cas.h) = 99518b262b1bc28c1d7d51e9e2cc8510b9c733b29b6d7af99fed145dcdc1af96
+SIZE (apache2/mod_auth_cas/1.0.9.1/mod_auth_cas.h) = 7630
diff --git a/www/mod_auth_cas/pkg-message b/www/mod_auth_cas/pkg-message
new file mode 100644
index 000000000000..78385befabf4
--- /dev/null
+++ b/www/mod_auth_cas/pkg-message
@@ -0,0 +1,32 @@
+======================================================================
+ Set a few required parameters in your Apache configuration:
+
+ CASCookiePath /var/cache/apache2/mod_auth_cas/
+ CASLoginURL https://login.example.org/cas/login
+ CASValidateURL https://login.example.org/cas/serviceValidate
+
+ Protect a "Location" or "Directory" block in your Apache configuration:
+
+ <Location /secured>
+ Authtype CAS
+ require valid-user
+ </Location>
+
+ If SAML-delivered attribute authorization is also desired, use the
+ samlValidate URL, enable SAML validation, and specify cas-attribute
+ in your require rule (please note: both attribute name and value are
+ case-sensitive):
+
+ CASCookiePath /var/cache/apache2/mod_auth_cas/
+ CASLoginURL https://login.example.org/cas/login
+ CASValidateURL https://login.example.org/cas/samlValidate
+ CASValidateSAML On
+
+ <Location /secured>
+ Authtype CAS
+ require cas-attribute edupersonaffiliation:staff
+ </Location>
+
+ For more informations see:
+ https://wiki.jasig.org/display/CASC/mod_auth_cas
+======================================================================