aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_cookie_mysql2
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-08-08 09:53:35 +0000
committerClement Laforet <clement@FreeBSD.org>2004-08-08 09:53:35 +0000
commitd445876bce32fc1119982b1eb1f1cd4be4b149b0 (patch)
treef8f0664f3418a74e83dfcd0d68ba9a55e199f842 /www/mod_auth_cookie_mysql2
parentb9fadce3134ae6690f9a4d8a05767575ab8f43bd (diff)
downloadports-d445876bce32fc1119982b1eb1f1cd4be4b149b0.tar.gz
ports-d445876bce32fc1119982b1eb1f1cd4be4b149b0.zip
Notes
Diffstat (limited to 'www/mod_auth_cookie_mysql2')
-rw-r--r--www/mod_auth_cookie_mysql2/Makefile36
-rw-r--r--www/mod_auth_cookie_mysql2/distinfo2
-rw-r--r--www/mod_auth_cookie_mysql2/pkg-descr4
3 files changed, 42 insertions, 0 deletions
diff --git a/www/mod_auth_cookie_mysql2/Makefile b/www/mod_auth_cookie_mysql2/Makefile
new file mode 100644
index 000000000000..d6e794bc6cd1
--- /dev/null
+++ b/www/mod_auth_cookie_mysql2/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mod_auth_cookie_mysql2
+# Date created: Sun Aug 8 2004
+# Whom: clement
+#
+# $FreeBSD$
+
+PORTNAME= mod_auth_cookie_mysql2
+PORTVERSION= 0.3
+CATEGORIES= www
+MASTER_SITES= http://home.digithi.de/digithi/dev/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+DIST_SUBDIR= apache2
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= Allows authentication against a MySQL database via a secure cookie
+
+USE_MYSQL= YES
+# If someone can test it with MySQL 4.1 ;-)
+BROKEN_WITH_MYSQL= 41
+
+WANT_APACHE= 2
+
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+AP_INC?= ${LOCALBASE}/include/mysql
+AP_LIB?= ${LOCALBASE}/lib/mysql -lmysqlclient -lz
+PORTDOCS= mod_auth_cookie_mysql2.html
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/mod_auth_cookie_mysql2/distinfo b/www/mod_auth_cookie_mysql2/distinfo
new file mode 100644
index 000000000000..13b3e7b90488
--- /dev/null
+++ b/www/mod_auth_cookie_mysql2/distinfo
@@ -0,0 +1,2 @@
+MD5 (apache2/mod_auth_cookie_mysql2_0.3.tar.gz) = e8c4dd0b14d31167710a2505a2cef2dc
+SIZE (apache2/mod_auth_cookie_mysql2_0.3.tar.gz) = 6741
diff --git a/www/mod_auth_cookie_mysql2/pkg-descr b/www/mod_auth_cookie_mysql2/pkg-descr
new file mode 100644
index 000000000000..afb833e1e825
--- /dev/null
+++ b/www/mod_auth_cookie_mysql2/pkg-descr
@@ -0,0 +1,4 @@
+This Apache module allows authentication against a MySQL database via a
+cryptographically secure cookie.
+
+WWW: http://home.digithi.de/digithi/dev/mod_auth_cookie_mysql2.html