aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_cookie_mysql2
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-06-20 19:28:09 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-06-20 19:28:09 +0000
commita7cf188844dbffc3fcb395e287120e25c54e7535 (patch)
treeb62b1fcf9cad0a3f17b065de7f29c566af034ae0 /www/mod_auth_cookie_mysql2
parent15c088992b2febdba1d18ee1e99463775334fbaf (diff)
Notes
Diffstat (limited to 'www/mod_auth_cookie_mysql2')
-rw-r--r--www/mod_auth_cookie_mysql2/Makefile11
-rw-r--r--www/mod_auth_cookie_mysql2/distinfo4
-rw-r--r--www/mod_auth_cookie_mysql2/pkg-descr7
3 files changed, 14 insertions, 8 deletions
diff --git a/www/mod_auth_cookie_mysql2/Makefile b/www/mod_auth_cookie_mysql2/Makefile
index bbdc13b6c126..b9900ffcca5c 100644
--- a/www/mod_auth_cookie_mysql2/Makefile
+++ b/www/mod_auth_cookie_mysql2/Makefile
@@ -5,17 +5,16 @@
# $FreeBSD$
PORTNAME= mod_auth_cookie_mysql2
-PORTVERSION= 0.9.a
-PORTREVISION= 1
+PORTVERSION= 1.0
CATEGORIES= www
MASTER_SITES= http://home.digithi.de/digithi/dev/mod_auth_cookie_mysql/
-DISTNAME= ${PORTNAME}_0.9a
-DIST_SUBDIR= apache20
+DISTNAME= ${PORTNAME}_1.0
+DIST_SUBDIR= apache22
MAINTAINER= apache@FreeBSD.org
COMMENT= Allows authentication against a MySQL database via a secure cookie
-MAKE_JOBS_SAFE= yes
+MAKE_JOBS_SAFE= yes
USE_MYSQL= YES
USE_APACHE= 20+
@@ -24,7 +23,7 @@ AP_FAST_BUILD= YES
AP_GENPLIST= YES
AP_EXTRAS= -DMODULE_NAME=${SHORTMODNAME} -DMODULE_NAME_module=${SHORTMODNAME}_module
AP_INC= ${LOCALBASE}/include/mysql
-AP_LIB= ${LOCALBASE}/lib/mysql
+AP_LIB= ${LOCALBASE}/lib/mysql -lmysqlclient
SRC_FILE= mod_auth_cookie_sql2.c mod_auth_cookie_sql2_mysql.c
.include <bsd.port.mk>
diff --git a/www/mod_auth_cookie_mysql2/distinfo b/www/mod_auth_cookie_mysql2/distinfo
index 75d9dbc19a87..8bbed5e14b21 100644
--- a/www/mod_auth_cookie_mysql2/distinfo
+++ b/www/mod_auth_cookie_mysql2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (apache20/mod_auth_cookie_mysql2_0.9a.tar.gz) = 8a4c6f838d7e793b891096f23f9a76ffc13e3d4d2f3925676276bdc570b4840e
-SIZE (apache20/mod_auth_cookie_mysql2_0.9a.tar.gz) = 7592
+SHA256 (apache22/mod_auth_cookie_mysql2_1.0.tar.gz) = 85601beea7a6de0ba8ef466027e6783cebef05c4687dc50460d2fdb06f5babe4
+SIZE (apache22/mod_auth_cookie_mysql2_1.0.tar.gz) = 7406
diff --git a/www/mod_auth_cookie_mysql2/pkg-descr b/www/mod_auth_cookie_mysql2/pkg-descr
index 21d6c3567991..2aeb491a61cf 100644
--- a/www/mod_auth_cookie_mysql2/pkg-descr
+++ b/www/mod_auth_cookie_mysql2/pkg-descr
@@ -1,4 +1,11 @@
This Apache module allows authentication against a MySQL database via a
cryptographically secure cookie.
+Features:
+ - Fake Basic Auth with cookies
+ - Cookie only consists of random session data, no username or password
+ - Can check expiry information stored in database against cookie
+ - Can check if the remote IP is equal to the IP stored in database
+ - Can be used for Single-Sign-On (SSO).
+
WWW: http://home.digithi.de/digithi/dev/mod_auth_cookie_mysql/