aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_cookie_mysql
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-10-14 08:45:54 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-10-14 08:45:54 +0000
commite3802278b47c2a0c48cffdc61ab98d6155eb163e (patch)
tree86868ed004e0c80b3059fb6cb2b299e4244f12aa /www/mod_auth_cookie_mysql
parent4dbd49b80f94cc3a07a6e86e06c9086e1099b91d (diff)
downloadports-e3802278b47c2a0c48cffdc61ab98d6155eb163e.tar.gz
ports-e3802278b47c2a0c48cffdc61ab98d6155eb163e.zip
Notes
Diffstat (limited to 'www/mod_auth_cookie_mysql')
-rw-r--r--www/mod_auth_cookie_mysql/Makefile42
-rw-r--r--www/mod_auth_cookie_mysql/distinfo1
-rw-r--r--www/mod_auth_cookie_mysql/pkg-descr4
-rw-r--r--www/mod_auth_cookie_mysql/pkg-plist8
4 files changed, 55 insertions, 0 deletions
diff --git a/www/mod_auth_cookie_mysql/Makefile b/www/mod_auth_cookie_mysql/Makefile
new file mode 100644
index 000000000000..673fdec81198
--- /dev/null
+++ b/www/mod_auth_cookie_mysql/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: mod_auth_cookie_mysql
+# Date created: Tue Oct 7
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+
+PORTNAME= mod_auth_cookie_mysql
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://sheepkiller.nerim.net/ports/${PORTNAME}/ \
+ http://www.cultdeadsheep.org/FreeBSD/ports/download/distfiles/
+# Original Location: http://www.qwk.net/opensource/mod_auth_cookie_mysql/mod_auth_cookie_mysql.tar.gz
+DIST_SUBDIR= apache
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= Allows authentication against a MySQL database via a secure cookie
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_MYSQL= YES
+# If someone can test it with MySQL 4.1 ;-)
+BROKEN_WITH_MYSQL= 41
+
+APXS?= ${LOCALBASE}/sbin/apxs
+MYSQL_INC?= ${LOCALBASE}/include/mysql
+MYSQL_LIBS?= ${LOCALBASE}/lib/mysql -lmysqlclient -lz
+
+do-build:
+ @(cd ${WRKSRC} && ${APXS} -I ${MYSQL_INC} -L ${MYSQL_LIBS} -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.so)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/authform.tmpl ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/putcookie.cgi ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_cookie_mysql/distinfo b/www/mod_auth_cookie_mysql/distinfo
new file mode 100644
index 000000000000..d737c84b9a22
--- /dev/null
+++ b/www/mod_auth_cookie_mysql/distinfo
@@ -0,0 +1 @@
+MD5 (apache/mod_auth_cookie_mysql-1.0.tar.gz) = 84ab8b4a0e19bfc3af808b11a399b050
diff --git a/www/mod_auth_cookie_mysql/pkg-descr b/www/mod_auth_cookie_mysql/pkg-descr
new file mode 100644
index 000000000000..3ded97c7627d
--- /dev/null
+++ b/www/mod_auth_cookie_mysql/pkg-descr
@@ -0,0 +1,4 @@
+This Apache module allows authentication against a MySQL database via a
+cryptographically secure cookie.
+
+WWW: http://www.qwk.net/opensource/mod_auth_cookie_mysql/
diff --git a/www/mod_auth_cookie_mysql/pkg-plist b/www/mod_auth_cookie_mysql/pkg-plist
new file mode 100644
index 000000000000..e635296f7988
--- /dev/null
+++ b/www/mod_auth_cookie_mysql/pkg-plist
@@ -0,0 +1,8 @@
+libexec/apache/mod_auth_cookie_mysql.so
+@exec %D/sbin/apxs -e -a -n auth_cookie_mysql %D/%f
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/authform.tmpl
+%%PORTDOCS%%%%EXAMPLESDIR%%/putcookie.cgi
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@unexec echo "===> If you do not plan on reinstalling mod_auth_cookie_mysql, you must manually remove"; echo "===> references to it in httpd.conf."