aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_cookie_mysql
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-04-16 14:40:41 +0000
committerClement Laforet <clement@FreeBSD.org>2004-04-16 14:40:41 +0000
commita69c5948a6f1963386e14deeb30f67e7effa3437 (patch)
tree2af54cfbab48afe5896f93ced40b13c518f36c61 /www/mod_auth_cookie_mysql
parent571fbc779323019f7d123d254e4b53512ed3ea5f (diff)
downloadports-a69c5948a6f1963386e14deeb30f67e7effa3437.tar.gz
ports-a69c5948a6f1963386e14deeb30f67e7effa3437.zip
Notes
Diffstat (limited to 'www/mod_auth_cookie_mysql')
-rw-r--r--www/mod_auth_cookie_mysql/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/www/mod_auth_cookie_mysql/Makefile b/www/mod_auth_cookie_mysql/Makefile
index 2be9cecce0a1..ba5c3e1db496 100644
--- a/www/mod_auth_cookie_mysql/Makefile
+++ b/www/mod_auth_cookie_mysql/Makefile
@@ -15,21 +15,19 @@ DIST_SUBDIR= apache
MAINTAINER= clement@FreeBSD.org
COMMENT= Allows authentication against a MySQL database via a secure cookie
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
USE_MYSQL= YES
# If someone can test it with MySQL 4.1 ;-)
BROKEN_WITH_MYSQL= 41
-APXS?= ${LOCALBASE}/sbin/apxs
-MYSQL_INC?= ${LOCALBASE}/include/mysql
-MYSQL_LIBS?= ${LOCALBASE}/lib/mysql -lmysqlclient -lz
+WANT_APACHE= 13
-do-build:
- @(cd ${WRKSRC} && ${APXS} -I ${MYSQL_INC} -L ${MYSQL_LIBS} -c ${PORTNAME}.c)
+AP_FAST_BUILD= YES
+AP_INC?= ${LOCALBASE}/include/mysql
+AP_LIB?= ${LOCALBASE}/lib/mysql -lmysqlclient -lz
-do-install:
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+post-install:
@(cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.so)
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -39,4 +37,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/putcookie.cgi ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>