aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_external2/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-10-14 10:57:45 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-10-14 10:57:45 +0000
commita63c2f44b779f102354b1fafd8ad3f531c9ad0c3 (patch)
tree56836d9b89c6b848e77ffb6d928cdf06d5209a59 /www/mod_auth_external2/Makefile
parentd3fb9ee8eab6532e8d8e56a901b8c2982e601672 (diff)
downloadports-a63c2f44b779f102354b1fafd8ad3f531c9ad0c3.tar.gz
ports-a63c2f44b779f102354b1fafd8ad3f531c9ad0c3.zip
Notes
Diffstat (limited to 'www/mod_auth_external2/Makefile')
-rw-r--r--www/mod_auth_external2/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/mod_auth_external2/Makefile b/www/mod_auth_external2/Makefile
new file mode 100644
index 000000000000..37a948453f99
--- /dev/null
+++ b/www/mod_auth_external2/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mod_auth_external2
+# Date created: Fri Oct 10
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+
+PORTNAME= mod_auth_external
+PORTVERSION= 2.2.6
+CATEGORIES= www
+MASTER_SITES= http://www.unixpapa.com/software/
+DIST_SUBDIR= apache
+
+MAINTAINER= sheeepkiller@cultdeadsheep.org
+COMMENT= Allows users authentication based on external mechanisms
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LATEST_LINK= mod_auth_external2
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+DOC_FILES= AUTHENTICATORS INSTALL README
+do-build:
+ @(cd ${WRKSRC}/ && ${APXS} -I. -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC}/ && ${APXS} -A -i ${PORTNAME}.la)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>