aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_external2
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-09-30 14:01:15 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-09-30 14:01:15 +0000
commit5bd67f364a39dfab8d85a432a624012e3a0bb7cc (patch)
tree4061eb6b57ef545dde5de148eddce1dfdfcf4745 /www/mod_auth_external2
parent5d6171eb2aa8d5deea550c89115589abb326ceaa (diff)
downloadports-5bd67f364a39dfab8d85a432a624012e3a0bb7cc.tar.gz
ports-5bd67f364a39dfab8d85a432a624012e3a0bb7cc.zip
Notes
Diffstat (limited to 'www/mod_auth_external2')
-rw-r--r--www/mod_auth_external2/Makefile2
-rw-r--r--www/mod_auth_external2/files/patch-mod_auth_external.c16
2 files changed, 17 insertions, 1 deletions
diff --git a/www/mod_auth_external2/Makefile b/www/mod_auth_external2/Makefile
index b05717961c36..f42272efe8b1 100644
--- a/www/mod_auth_external2/Makefile
+++ b/www/mod_auth_external2/Makefile
@@ -14,7 +14,7 @@ COMMENT= Allows users authentication based on external mechanisms
LICENSE= APACHE20
-USE_APACHE= 22
+USE_APACHE= 22+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SHORTMODNAME= auth_external
diff --git a/www/mod_auth_external2/files/patch-mod_auth_external.c b/www/mod_auth_external2/files/patch-mod_auth_external.c
new file mode 100644
index 000000000000..21de308e2c57
--- /dev/null
+++ b/www/mod_auth_external2/files/patch-mod_auth_external.c
@@ -0,0 +1,16 @@
+--- mod_auth_external.c.orig 2006-02-15 22:44:53 UTC
++++ mod_auth_external.c
+@@ -500,8 +500,13 @@
+ if (remote_host != NULL)
+ child_env[i++]= apr_pstrcat(r->pool, ENV_HOST"=", remote_host, NULL);
+
++#if MODULE_MAGIC_NUMBER_MAJOR >= 20111130
++ if (c->client_ip)
++ child_env[i++]= apr_pstrcat(r->pool, ENV_IP"=", c->client_ip, NULL);
++#else
+ if (c->remote_ip)
+ child_env[i++]= apr_pstrcat(r->pool, ENV_IP"=", c->remote_ip, NULL);
++#endif
+
+ if (r->uri)
+ child_env[i++]= apr_pstrcat(r->pool, ENV_URI"=", r->uri, NULL);