aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_kerb/Makefile
diff options
context:
space:
mode:
authorGarrett Wollman <wollman@FreeBSD.org>2001-10-19 17:40:18 +0000
committerGarrett Wollman <wollman@FreeBSD.org>2001-10-19 17:40:18 +0000
commita3db454330be3b2c6b0d59f8afe30fdff03928f3 (patch)
tree73c624884cdd44e42448a94f0845b392150cd761 /www/mod_auth_kerb/Makefile
parentc7ac426c13fc7d0af2bac36d10642fe0f192a5c7 (diff)
downloadports-a3db454330be3b2c6b0d59f8afe30fdff03928f3.tar.gz
ports-a3db454330be3b2c6b0d59f8afe30fdff03928f3.zip
Notes
Diffstat (limited to 'www/mod_auth_kerb/Makefile')
-rw-r--r--www/mod_auth_kerb/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/www/mod_auth_kerb/Makefile b/www/mod_auth_kerb/Makefile
new file mode 100644
index 000000000000..f8939c23f667
--- /dev/null
+++ b/www/mod_auth_kerb/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: mod_auth_kerb
+# Date created: 19 October 2001
+# Whom: wollman
+#
+# $FreeBSD$
+#
+
+# Shamelessly stolen from will's mod_auth_any port.
+
+PORTNAME= mod_auth_kerb
+PORTVERSION= 4.10
+CATEGORIES= www
+MASTER_SITES= http://stonecold.unity.ncsu.edu/software/mod_auth_kerb/downloads/
+
+MAINTAINER= wollman@FreeBSD.org
+
+#
+# This module allows users to send their Kerberos password in
+# plain text; it should only be used over an encrypted connection
+# (i.e., HTTP over SSL/TLS). Thus, we require as a dependency
+# a version of Apache which can do this.
+#
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13-modssl
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13-modssl
+LIB_DEPENDS= krb5.3:${PORTSDIR}/security/krb5
+
+WRKSRC= ${WRKDIR}/src/modules/kerberos
+
+APXS?= ${LOCALBASE}/sbin/apxs
+KRB5_HOME?= ${LOCALBASE}
+
+do-build:
+ cd ${WRKSRC} && \
+ ${APXS} -I${KRB5_HOME}/include -L${KRB5_HOME}/lib \
+ -DKRB5 -DKRB5_VERIFY_TICKET -DKRB5_SAVE_CREDENTIALS \
+ -DKRB5_DEFAULT_KEYTAB=\"\\\"file:${LOCALBASE}/etc/apache/keytab\\\"\" \
+ -c ${PORTNAME}.c
+
+do-install:
+ ${APXS} -i -A -n ${PORTNAME:S/mod_//g} ${WRKSRC}/${PORTNAME}.so
+
+.include <bsd.port.mk>