aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_kerb2/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-07-23 14:45:19 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-07-23 14:45:19 +0000
commit8ac56fd10be41571908625e18b58d2921b1587a9 (patch)
treec7e0fdc6f1ac4b7fe42815b05472a670560fa800 /www/mod_auth_kerb2/Makefile
parenta37f96b98e4a4992bf798fa0bdc9c8da798623c0 (diff)
downloadports-8ac56fd10be41571908625e18b58d2921b1587a9.tar.gz
ports-8ac56fd10be41571908625e18b58d2921b1587a9.zip
Notes
Diffstat (limited to 'www/mod_auth_kerb2/Makefile')
-rw-r--r--www/mod_auth_kerb2/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index e95a413645f2..89d000a7af52 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -27,13 +27,6 @@ USE_GMAKE= yes
# Don't fsck with CFLAGS
CFLAGS:=
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-krb5=${KRB5_HOME} --without-krb4
-OPTIONS+= BASE_KERBEROS5 "Use the base Kerberos 5 (Heimdal)"
-.if exists(/usr/lib/libkrb5.so)
-OPTIONS+= on
-.else
-OPTIONS+= off
-.endif
.include <bsd.port.pre.mk>
@@ -47,11 +40,16 @@ APACHE_MODULE_DIR!=${PREFIX}/sbin/apxs -q LIBEXECDIR
APACHE_MODULE_DIR=libexec/apache
.endif
PLIST_SUB+= APMODDIR=${APACHE_MODULE_DIR:S/^${PREFIX}\///}
-.if defined(WITH_BASE_KERBEROS5)
-KRB5_HOME= /usr
+
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
+CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME} --without-krb4
+.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
+CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME} --without-krb4
+.elif exists(${DESTDIR}/usr/lib/libkrb5.a) && exists(${DESTDIR}/usr/bin/krb5-config)
+CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr --without-krb4
.else
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
-KRB5_HOME= ${LOCALBASE}
+LIB_DEPENDS+= krb5:${PORTSDIR}/security/krb5
+CONFIGURE_ARGS+= --with-krb5=${LOCALBASE} --without-krb4
.endif
.include <bsd.port.post.mk>