aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_kerb2
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-11 07:42:53 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-11 07:42:53 +0000
commit9905458b8114d502c0f96eaeb5367bb1665a57c1 (patch)
tree76a55654e98e39b684fa4b877ebaf890b6f12c8c /www/mod_auth_kerb2
parent0cba85945afbad9f90a89252dd4994a3031422c5 (diff)
downloadports-9905458b8114d502c0f96eaeb5367bb1665a57c1.tar.gz
ports-9905458b8114d502c0f96eaeb5367bb1665a57c1.zip
Notes
Diffstat (limited to 'www/mod_auth_kerb2')
-rw-r--r--www/mod_auth_kerb2/Makefile29
-rw-r--r--www/mod_auth_kerb2/pkg-plist2
2 files changed, 9 insertions, 22 deletions
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index 3ea9738cfd52..df9d5d54df17 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -1,10 +1,11 @@
-# New ports collection makefile for: mod_auth_kerb
-# Date created: 19 October 2001
-# Whom: wollman
+# New ports collection makefile for: mod_auth_kerb
+# Date created: 19 October 2001
+# Whom: wollman
#
# $FreeBSD$
#
+
# Shamelessly stolen from will's mod_auth_any port.
PORTNAME= mod_auth_kerb
@@ -16,27 +17,13 @@ MASTER_SITE_SUBDIR=modauthkerb
MAINTAINER= apache@FreeBSD.org
COMMENT= An Apache module for authenticating users with Kerberos v5
-LATEST_LINK= mod_auth_kerb2
-#
-# This module allows users to send their Kerberos password in
-# plain text; it should only be used over an encrypted connection
-# (i.e., HTTP over SSL/TLS). Thus, we require as a dependency
-# a version of Apache which can do this.
-#
+LATEST_LINK= mod_auth_kerb2
+
USE_APACHE= 2.0+
USE_GMAKE= yes
-# Don't fsck with CFLAGS
-CFLAGS:=
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if exists(${PREFIX}/sbin/apxs)
-APACHE_MODULE_DIR!=${PREFIX}/sbin/apxs -q LIBEXECDIR
-.else
-APACHE_MODULE_DIR=libexec/apache
-.endif
-PLIST_SUB+= APMODDIR=${APACHE_MODULE_DIR:S/^${PREFIX}\///}
+PORTSCOUT= limit:^5.3
.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME} --without-krb4
@@ -49,4 +36,4 @@ LIB_DEPENDS+= krb5:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-krb5=${LOCALBASE} --without-krb4
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/mod_auth_kerb2/pkg-plist b/www/mod_auth_kerb2/pkg-plist
index e10a6259ef13..cd2cc90e3dc4 100644
--- a/www/mod_auth_kerb2/pkg-plist
+++ b/www/mod_auth_kerb2/pkg-plist
@@ -1,3 +1,3 @@
-%%APMODDIR%%/mod_auth_kerb.so
+%%APACHEMODDIR%%/mod_auth_kerb.so
@exec %D/sbin/apxs -e -A -n auth_kerb %D/%F
@unexec %D/sbin/apxs -e -A -n auth_kerb %D/%F