aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_mysql
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2004-02-24 11:00:07 +0000
committerJames E. Housley <jeh@FreeBSD.org>2004-02-24 11:00:07 +0000
commit7c3a4289514802f9e9c29a8b6fce1f566b6b76a6 (patch)
treee02a940e6141622d1e5e6e08188b42ed74322bcd /www/mod_auth_mysql
parentfc1ce0f4df337ec1d82dcbe9517ac4fd2c0aee91 (diff)
downloadports-7c3a4289514802f9e9c29a8b6fce1f566b6b76a6.tar.gz
ports-7c3a4289514802f9e9c29a8b6fce1f566b6b76a6.zip
Notes
Diffstat (limited to 'www/mod_auth_mysql')
-rw-r--r--www/mod_auth_mysql/Makefile2
-rw-r--r--www/mod_auth_mysql/files/patch-ad11
-rw-r--r--www/mod_auth_mysql/pkg-descr2
3 files changed, 8 insertions, 7 deletions
diff --git a/www/mod_auth_mysql/Makefile b/www/mod_auth_mysql/Makefile
index 9373e169d6f0..97347a88fa8c 100644
--- a/www/mod_auth_mysql/Makefile
+++ b/www/mod_auth_mysql/Makefile
@@ -6,7 +6,7 @@
PORTNAME= mod_auth_mysql
PORTVERSION= 2.20
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mod-auth-mysql
diff --git a/www/mod_auth_mysql/files/patch-ad b/www/mod_auth_mysql/files/patch-ad
index 0d22b3a8ef91..2e305c698b45 100644
--- a/www/mod_auth_mysql/files/patch-ad
+++ b/www/mod_auth_mysql/files/patch-ad
@@ -1,10 +1,11 @@
--- mod_auth_mysql.c.orig Sat Oct 3 13:41:41 1998
-+++ mod_auth_mysql.c Sun Sep 28 14:21:47 2003
-@@ -372,7 +372,11 @@
++++ mod_auth_mysql.c Tue Feb 24 05:53:32 2004
+@@ -372,7 +372,12 @@
}
if (name != NULL) { /* open an SQL link */
/* link to the MySQL database and register its cleanup!@$ */
+#if MYSQL_VERSION_ID >= 40000
++ mysql_init(&auth_sql_server);
+ mysql_auth = mysql_real_connect(&auth_sql_server, auth_db_host, user, pwd, name, 0, NULL, 0);
+#else /* MYSQL_VERSION_ID < 40000 */
mysql_auth = mysql_connect(&auth_sql_server, auth_db_host, user, pwd);
@@ -12,7 +13,7 @@
if (sec->non_persistent && mysql_auth) {
note_cleanups_for_mysql_auth(r->pool, mysql_auth);
}
-@@ -559,6 +563,10 @@
+@@ -559,6 +564,10 @@
switch (mysql_check_user_password(r, c->user, sent_pw, sec)) {
case 0:
@@ -23,7 +24,7 @@
note_basic_auth_failure(r);
return AUTH_REQUIRED;
break;
-@@ -582,6 +590,7 @@
+@@ -582,6 +591,7 @@
{
mysql_auth_config_rec *sec = (mysql_auth_config_rec *) get_module_config(r->per_dir_config, &auth_mysql_module);
char *user = r->connection->user;
@@ -31,7 +32,7 @@
int m = r->method_number;
int method_restricted = 0;
register int x;
-@@ -653,6 +662,10 @@
+@@ -653,6 +663,10 @@
if (!(sec->assume_authoritative)) {
return DECLINED;
}
diff --git a/www/mod_auth_mysql/pkg-descr b/www/mod_auth_mysql/pkg-descr
index 005308d39739..4813b6011d32 100644
--- a/www/mod_auth_mysql/pkg-descr
+++ b/www/mod_auth_mysql/pkg-descr
@@ -1,6 +1,6 @@
This add-on module allows the apache web server to use a MySQL database for user and/or group authentication. For large user lists this can offer a significate speed up over apache's standard flat file format.
-WWW: http://sourceforge.net/projects/authmysql-admin/
+WWW: http://www.diegonet.com/support/mod_auth_mysql.shtml
- Jim
jim@thehousleys.net