aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_mysql_another
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-06 04:48:05 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-06 04:48:05 +0000
commitf2d4e371ffaac78212b5d1db3183d20a7844d2c4 (patch)
tree43a1a0d10f54d5b5639bcb367f95be6766c7942b /www/mod_auth_mysql_another
parent614f70eaf1575cb95a431b61ed347230277ace27 (diff)
downloadports-f2d4e371ffaac78212b5d1db3183d20a7844d2c4.tar.gz
ports-f2d4e371ffaac78212b5d1db3183d20a7844d2c4.zip
Notes
Diffstat (limited to 'www/mod_auth_mysql_another')
-rw-r--r--www/mod_auth_mysql_another/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/www/mod_auth_mysql_another/Makefile b/www/mod_auth_mysql_another/Makefile
index 76d83faeab19..a8a3d15d72b6 100644
--- a/www/mod_auth_mysql_another/Makefile
+++ b/www/mod_auth_mysql_another/Makefile
@@ -14,26 +14,25 @@ PKGNAMESUFFIX= _another
MAINTAINER= mbr@FreeBSD.org
COMMENT= Allows users to use MySQL databases for user authentication
-MAKE_JOBS_SAFE= yes
+MAKE_JOBS_SAFE= yes
USE_MYSQL= YES
+USE_APACHE= 13+
-SHORTMODNAME= mysql_auth
-AP_FAST_BUILD= YES
-AP_GENPLIST= YES
-AP_INC= ${LOCALBASE}/include/mysql
-AP_LIB= ${LOCALBASE}/lib/mysql
-.if defined(WITH_APACHE2)
+SHORTMODNAME= mysql_auth
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+AP_INC= ${LOCALBASE}/include/mysql
+AP_LIB= ${LOCALBASE}/lib/mysql
AP_EXTRAS= -lmysqlclient -lz -lm
-USE_APACHE= 20+
-.else
-USE_APACHE= 13+
-AP_EXTRAS= -DAPACHE${AP_VER} -lmysqlclient -lz -lm
-.endif
.include <bsd.port.pre.mk>
-.if defined(WITH_APACHE2)
+.if ${APACHE_VERSION} > 20
+AP_EXTRAS+= -DAPACHE2
+.endif
+
+.if ${APACHE_VERSION} > 20
post-patch:
${REINPLACE_CMD} -e "s|APR_XtOffsetOf|APR_OFFSETOF|g" \
-e "s|APR_XtOffset|APR_OFFSET|g" ${WRKSRC}/mod_auth_mysql.c