aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_pam2/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-10-07 10:34:59 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-10-07 10:34:59 +0000
commit3998cfee5f1c5c570467e6d51b9f9f4343a1c5eb (patch)
treee7ee43fd3d5c532e729a7a67bd069549bdc2cd13 /www/mod_auth_pam2/Makefile
parentbfe5be6beaafd536dfd33f56d931417872aa4e55 (diff)
downloadports-3998cfee5f1c5c570467e6d51b9f9f4343a1c5eb.tar.gz
ports-3998cfee5f1c5c570467e6d51b9f9f4343a1c5eb.zip
Notes
Diffstat (limited to 'www/mod_auth_pam2/Makefile')
-rw-r--r--www/mod_auth_pam2/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/mod_auth_pam2/Makefile b/www/mod_auth_pam2/Makefile
new file mode 100644
index 000000000000..1b953a048c09
--- /dev/null
+++ b/www/mod_auth_pam2/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mod_auth_pam2
+# Date created: Sun Oct 5
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_auth_pam
+PORTVERSION= 1.1.1
+CATEGORIES= www
+MASTER_SITES= http://pam.sourceforge.net/mod_auth_pam/dist/
+DISTNAME= ${PORTNAME}-2.0-${PORTVERSION}
+
+MAINTAINER= sheepkiller@cotds.org
+COMMENT= Allows users to use PAM modules for user authentication
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LATEST_LINK= mod_auth_pam2
+
+USE_GMAKE= YES
+MAKE_ENV+= APXS=${APXS}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+APXS?= ${LOCALBASE}/sbin/apxs
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/httpd ${EXAMPLESDIR}/pam-httpd.sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>