aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_pgsql2
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-08-25 14:58:09 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-08-25 14:58:09 +0000
commite00461bd26686c219ee0e837fb55568039e8ea36 (patch)
tree966ed5829666920bedd6a6ec7d9084bcd3b4e909 /www/mod_auth_pgsql2
parent750c7b06b1263b38ebcaa4e0c8bbcb099b02d056 (diff)
downloadports-e00461bd26686c219ee0e837fb55568039e8ea36.tar.gz
ports-e00461bd26686c219ee0e837fb55568039e8ea36.zip
Notes
Diffstat (limited to 'www/mod_auth_pgsql2')
-rw-r--r--www/mod_auth_pgsql2/Makefile2
-rw-r--r--www/mod_auth_pgsql2/files/patch-mod_auth_pgsql.c16
2 files changed, 17 insertions, 1 deletions
diff --git a/www/mod_auth_pgsql2/Makefile b/www/mod_auth_pgsql2/Makefile
index e6eb05032fb0..58beacfc409d 100644
--- a/www/mod_auth_pgsql2/Makefile
+++ b/www/mod_auth_pgsql2/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= apache@FreeBSD.org
COMMENT= Allows users to use PostgreSQL databases for user authentication
USES= pgsql
-USE_APACHE= 22
+USE_APACHE= 22+
AP_INC?= ${LOCALBASE}/include
AP_LIB?= ${LOCALBASE}/lib -lpq
diff --git a/www/mod_auth_pgsql2/files/patch-mod_auth_pgsql.c b/www/mod_auth_pgsql2/files/patch-mod_auth_pgsql.c
new file mode 100644
index 000000000000..ed19d0cc0382
--- /dev/null
+++ b/www/mod_auth_pgsql2/files/patch-mod_auth_pgsql.c
@@ -0,0 +1,16 @@
+--- ./mod_auth_pgsql.c.orig 2006-01-05 15:15:13.000000000 +0100
++++ ./mod_auth_pgsql.c 2014-08-25 16:53:20.000000000 +0200
+@@ -1060,8 +1060,13 @@
+ apr_snprintf(sql, MAX_STRING_LEN, ", %s",
+ sec->auth_pg_log_addrs_field);
+ strncat(fields, sql, MAX_STRING_LEN - strlen(fields) - 1);
++#if MODULE_MAGIC_NUMBER_MAJOR >= 20111130
++ apr_snprintf(sql, MAX_STRING_LEN, ", '%s'",
++ r->useragent_ip);
++#else
+ apr_snprintf(sql, MAX_STRING_LEN, ", '%s'",
+ r->connection->remote_ip);
++#endif
+ strncat(values, sql, MAX_STRING_LEN - strlen(values) - 1);
+ }
+ if (sec->auth_pg_log_pwd_field) { /* Password field , clear WARNING */