aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_pwcheck/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-19 03:12:05 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-19 03:12:05 +0000
commitec5fa6bf1815d1df455589933f7a7f572333778f (patch)
treeb7697c0225b5254359296052d9f255e42c48fbb0 /www/mod_auth_pwcheck/Makefile
parent4e5898abc93d2fc3528d1011888b5342392e9f1d (diff)
downloadports-ec5fa6bf1815d1df455589933f7a7f572333778f.tar.gz
ports-ec5fa6bf1815d1df455589933f7a7f572333778f.zip
Notes
Diffstat (limited to 'www/mod_auth_pwcheck/Makefile')
-rw-r--r--www/mod_auth_pwcheck/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/www/mod_auth_pwcheck/Makefile b/www/mod_auth_pwcheck/Makefile
new file mode 100644
index 000000000000..17407b1635c8
--- /dev/null
+++ b/www/mod_auth_pwcheck/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: mod_auth_pwcheck
+# Date created: 2001/08/08
+# Whom: Anton Voronin <anton@urc.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_auth_pwcheck
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://www.chelcom.ru/~anton/projects/files/
+
+MAINTAINER= anton@urc.ac.ru
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${AP_CATEGORY}/${AP_PORT}
+RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${PORTSDIR}/${AP_CATEGORY}/${AP_PORT} \
+ ${LOCALBASE}/sbin/pwcheck:${PORTSDIR}/security/cyrus-sasl
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+APXS?= ${LOCALBASE}/sbin/apxs
+.if exists(${APXS})
+AP_MOD_SSL_SUFFIX!= ${APXS} -q CFLAGS | ${GREP} DMOD_SSL >/dev/null \
+ || ${ECHO} -modssl
+AP_CATEGORY!= ${APXS} -q CFLAGS | ${GREP} DRUSSIAN_APACHE >/dev/null \
+ || ${ECHO} www
+AP_TARGET!= ${APXS} -q TARGET
+AP_LIBEXEC!= ${APXS} -q LIBEXECDIR | ${SED} 's@^${PREFIX}/@@'
+.else
+AP_CATEGORY= www
+.endif
+
+AP_PORT= apache13${AP_MOD_SSL_SUFFIX}
+AUTH_PWCHECK_DOCS= share/doc/apache/manual/mod/mod_auth_pwcheck
+PLIST_SUB= AUTH_PWCHECK_DOCS="${AUTH_PWCHECK_DOCS}" \
+ AP_LIBEXEC="${AP_LIBEXEC}" \
+ APXS="${APXS}"
+
+.include <bsd.port.post.mk>