aboutsummaryrefslogtreecommitdiff
path: root/www/mod_authenticache
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-10-14 10:47:09 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-10-14 10:47:09 +0000
commit09c98d8ef3ccd2403f0546d943c8e2d8d2616931 (patch)
tree92e9d483293c18f74c9445fd380f8c39b7d7a576 /www/mod_authenticache
parent11cb37f1c037c5c106466b3bd4b61140638a759a (diff)
downloadports-09c98d8ef3ccd2403f0546d943c8e2d8d2616931.tar.gz
ports-09c98d8ef3ccd2403f0546d943c8e2d8d2616931.zip
Notes
Diffstat (limited to 'www/mod_authenticache')
-rw-r--r--www/mod_authenticache/Makefile27
-rw-r--r--www/mod_authenticache/distinfo1
-rw-r--r--www/mod_authenticache/pkg-descr10
-rw-r--r--www/mod_authenticache/pkg-plist3
4 files changed, 41 insertions, 0 deletions
diff --git a/www/mod_authenticache/Makefile b/www/mod_authenticache/Makefile
new file mode 100644
index 000000000000..979f63b1647c
--- /dev/null
+++ b/www/mod_authenticache/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mod_authenticache
+# Date created: Fri Oct 10
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+
+PORTNAME= mod_authenticache
+PORTVERSION= 2.0.6
+CATEGORIES= www
+MASTER_SITES= http://killa.net/infosec/mod_authenticache/
+DIST_SUBDIR= apache
+
+MAINTAINER= sheeepkiller@cultdeadsheep.org
+COMMENT= A generic credential caching module for Apache 2.0.x
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-build:
+ @(cd ${WRKSRC}/ && ${APXS} -I. -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC}/ && ${APXS} -A -i ${PORTNAME}.la)
+
+.include <bsd.port.mk>
diff --git a/www/mod_authenticache/distinfo b/www/mod_authenticache/distinfo
new file mode 100644
index 000000000000..f3bd437b79e4
--- /dev/null
+++ b/www/mod_authenticache/distinfo
@@ -0,0 +1 @@
+MD5 (apache/mod_authenticache-2.0.6.tar.gz) = 9f6934343be8a585ba3a720aa3ee8e5a
diff --git a/www/mod_authenticache/pkg-descr b/www/mod_authenticache/pkg-descr
new file mode 100644
index 000000000000..7769c4fb216a
--- /dev/null
+++ b/www/mod_authenticache/pkg-descr
@@ -0,0 +1,10 @@
+As HTTP is a relatively stateless protocol, each request generates an
+authentication attempt. While this is cheap when authenticating against dbm or
+htpasswd files, it can get very expensive when running against a Windows
+domain controller, ACE server, or other networked database, particularly on
+image-rich pages and FancyIndexes from mod_autoindex.
+
+mod_authenticache provides a secure method of caching credentials in order to
+more efficiently serve in these situations.
+
+WWW: http://killa.net/infosec/mod_authenticache/
diff --git a/www/mod_authenticache/pkg-plist b/www/mod_authenticache/pkg-plist
new file mode 100644
index 000000000000..68afcc83352a
--- /dev/null
+++ b/www/mod_authenticache/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache2/mod_authenticache.so
+@exec %D/sbin/apxs -e -a -n authenticache %D/%f
+@unexec echo "===> If you do not plan on reinstalling mod_authenticache, you must manually remove"; echo "===> references to it in httpd.conf."