aboutsummaryrefslogtreecommitdiff
path: root/www/mod_authenticache
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-03-06 14:09:42 +0000
committerClement Laforet <clement@FreeBSD.org>2004-03-06 14:09:42 +0000
commit312235c1659b5fa36d274b11c9f1ed0d041443ac (patch)
tree0fd411af3b5064bf2c5b66d220d9de6ca5137d3e /www/mod_authenticache
parent8afb837efdcfee51e0a90a36fc20b67e8516d7a4 (diff)
downloadports-312235c1659b5fa36d274b11c9f1ed0d041443ac.tar.gz
ports-312235c1659b5fa36d274b11c9f1ed0d041443ac.zip
Notes
Diffstat (limited to 'www/mod_authenticache')
-rw-r--r--www/mod_authenticache/Makefile18
-rw-r--r--www/mod_authenticache/distinfo4
-rw-r--r--www/mod_authenticache/files/patch-Makefile31
-rw-r--r--www/mod_authenticache/pkg-plist3
4 files changed, 41 insertions, 15 deletions
diff --git a/www/mod_authenticache/Makefile b/www/mod_authenticache/Makefile
index 518b8270f9ec..a0477e4934ec 100644
--- a/www/mod_authenticache/Makefile
+++ b/www/mod_authenticache/Makefile
@@ -5,23 +5,17 @@
# $FreeBSD$
PORTNAME= mod_authenticache
-PORTVERSION= 2.0.6
+PORTVERSION= 2.0.8
CATEGORIES= www
MASTER_SITES= http://killa.net/infosec/mod_authenticache/
-DIST_SUBDIR= apache
+DIST_SUBDIR= apache2
MAINTAINER= clement@FreeBSD.org
COMMENT= A generic credential caching module for Apache 2.0.x
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
-APXS?= ${LOCALBASE}/sbin/apxs
-
-do-build:
- @(cd ${WRKSRC}/ && ${APXS} -I. -c ${PORTNAME}.c)
-
-do-install:
- @(cd ${WRKSRC}/ && ${APXS} -A -i ${PORTNAME}.la)
+USE_APACHE= YES
+WITH_APACHE2= YES
+USE_GMAKE= YES
+MAKE_ENV+= APXS="${APXS}"
.include <bsd.port.mk>
diff --git a/www/mod_authenticache/distinfo b/www/mod_authenticache/distinfo
index a6e5449597ab..1306968bff7b 100644
--- a/www/mod_authenticache/distinfo
+++ b/www/mod_authenticache/distinfo
@@ -1,2 +1,2 @@
-MD5 (apache/mod_authenticache-2.0.6.tar.gz) = 9f6934343be8a585ba3a720aa3ee8e5a
-SIZE (apache/mod_authenticache-2.0.6.tar.gz) = 6254
+MD5 (apache2/mod_authenticache-2.0.8.tar.gz) = 1dd4f527ba964232ab7eb2df1765208c
+SIZE (apache2/mod_authenticache-2.0.8.tar.gz) = 6260
diff --git a/www/mod_authenticache/files/patch-Makefile b/www/mod_authenticache/files/patch-Makefile
new file mode 100644
index 000000000000..24350cb0288d
--- /dev/null
+++ b/www/mod_authenticache/files/patch-Makefile
@@ -0,0 +1,31 @@
+--- Makefile.orig Sat Mar 6 02:03:42 2004
++++ Makefile Sat Mar 6 12:04:51 2004
+@@ -3,14 +3,16 @@
+ NAME = mod_authenticache
+ VERSION = 2.0.8
+
+-CC = `apxs -q CC`
++CC = `${APXS} -q CC`
+ DEFS = -DVERSION=\"$(VERSION)\"
+-INCS = -I`apxs -q INCLUDEDIR`
+-FLGS = -s -O3 -Wall -pipe
++INCS = -I`${APXS} -q INCLUDEDIR`
++FLGS = ${CFLAGS}
+ OBJS = $(NAME).o
+ #EXPS = /u/webs/ap-home/modules/httpd.exp /u/webs/ap-home/lib/apr.exp /u/webs/ap-home/lib/aprutil.exp
+ #LIBS = -L../truerand -lrand
+
++all: $(NAME).so
++
+ $(NAME).so: $(OBJS) $(EXPS)
+ $(CC) $(FLGS) -fpic -shared -o $@ $^ $(LIBS)
+
+@@ -21,7 +23,7 @@
+ -rm -f *.o *.so
+
+ install: $(NAME).so
+- -cp -p $(NAME).so `apxs -q LIBEXECDIR`
++ -cp -p $(NAME).so `${APXS} -q LIBEXECDIR`
+
+ dist: clean
+ ( cd ..; \
diff --git a/www/mod_authenticache/pkg-plist b/www/mod_authenticache/pkg-plist
index 68afcc83352a..8f917bcf2fa0 100644
--- a/www/mod_authenticache/pkg-plist
+++ b/www/mod_authenticache/pkg-plist
@@ -1,3 +1,4 @@
libexec/apache2/mod_authenticache.so
-@exec %D/sbin/apxs -e -a -n authenticache %D/%f
+@exec %D/sbin/apxs -e -A -n authenticache %D/%f
+@unexec %D/sbin/apxs -e -A -n authenticache %D/%f
@unexec echo "===> If you do not plan on reinstalling mod_authenticache, you must manually remove"; echo "===> references to it in httpd.conf."