aboutsummaryrefslogtreecommitdiff
path: root/www/mod_authn_otp
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-08-25 22:43:06 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-08-25 22:43:06 +0000
commitf96ef332b3fc64ce4ff9dc955d73a349885f6732 (patch)
tree8b2aa12fb97d3dc1988414d1b3005b8eedca775d /www/mod_authn_otp
parent4bb8979ff27c102989d7526382f9c590801d7407 (diff)
downloadports-f96ef332b3fc64ce4ff9dc955d73a349885f6732.tar.gz
ports-f96ef332b3fc64ce4ff9dc955d73a349885f6732.zip
Notes
Diffstat (limited to 'www/mod_authn_otp')
-rw-r--r--www/mod_authn_otp/Makefile9
-rw-r--r--www/mod_authn_otp/pkg-plist5
2 files changed, 14 insertions, 0 deletions
diff --git a/www/mod_authn_otp/Makefile b/www/mod_authn_otp/Makefile
index 9cc8c51583f3..2c2bcb6d6eb6 100644
--- a/www/mod_authn_otp/Makefile
+++ b/www/mod_authn_otp/Makefile
@@ -2,12 +2,15 @@
# Date created: 03 05 2012
# Whom: Alexander Hausner <alex@hugo.bmg.gv.at>
# $FreeBSD$
+#
PORTNAME= mod_authn_otp
PORTVERSION= 1.1.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://mod-authn-otp.googlecode.com/files/ \
http://alex.bmg.gv.at/programs/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DIST_SUBDIR= apache2
MAINTAINER= alex@hugo.bmg.gv.at
@@ -18,11 +21,17 @@ MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes
USE_APACHE= 22+
+MAN1= otptool.1
+
PORTEXAMPLES= users.sample
.include <bsd.port.options.mk>
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --mandir=${MANPREFIX}/man
+
post-install:
+ @${APXS} -e -A -n ${PORTNAME:S/mod_//} ${APACHEMODDIR}/${PORTNAME}.so
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/users.sample ${EXAMPLESDIR}/
diff --git a/www/mod_authn_otp/pkg-plist b/www/mod_authn_otp/pkg-plist
new file mode 100644
index 000000000000..3cf0d6a81f1f
--- /dev/null
+++ b/www/mod_authn_otp/pkg-plist
@@ -0,0 +1,5 @@
+@unexec sed -i '' -E '/LoadModule[[:blank:]]+authn_otp_module/d' %D/%%APACHEETCDIR%%/httpd.conf
+%%APACHEMODDIR%%/mod_authn_otp.so
+@exec %D/sbin/apxs -e -A -n authn_otp %D/%F
+@unexec echo \"Don\'t forget to remove all mod_authn_otp-related directives in your httpd.conf\"
+bin/otptool