aboutsummaryrefslogtreecommitdiff
path: root/www/mod_authn_sasl
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2009-02-18 15:35:11 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2009-02-18 15:35:11 +0000
commit587f7853badb12c7df8ef07f670279ecdbe06f94 (patch)
tree8d9371d09f89fb67cfa89246eb32576fcf86635c /www/mod_authn_sasl
parentdadcceed227ffa04b496192d0fca421c42aac7a4 (diff)
downloadports-587f7853badb12c7df8ef07f670279ecdbe06f94.tar.gz
ports-587f7853badb12c7df8ef07f670279ecdbe06f94.zip
Notes
Diffstat (limited to 'www/mod_authn_sasl')
-rw-r--r--www/mod_authn_sasl/Makefile45
-rw-r--r--www/mod_authn_sasl/distinfo3
-rw-r--r--www/mod_authn_sasl/pkg-descr6
3 files changed, 54 insertions, 0 deletions
diff --git a/www/mod_authn_sasl/Makefile b/www/mod_authn_sasl/Makefile
new file mode 100644
index 000000000000..0e7e07e13723
--- /dev/null
+++ b/www/mod_authn_sasl/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mod_authn_sasl
+# Date created: February 16, 2009
+# Whom: Joerg Pulz <Joerg.Pulz@frm2.tum.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_authn_sasl
+PORTVERSION= 1.0.2
+CATEGORIES= www
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/g}
+
+MAINTAINER= Joerg.Pulz@frm2.tum.de
+COMMENT= Allows user authentication based on libsasl2 mechanisms on apache 2.2
+
+LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+
+FETCH_BEFORE_ARGS= -v -v
+
+USE_APACHE= 22
+USE_BZIP2= yes
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+#SHORTMODNAME= authn_sasl
+
+OPTIONS= SASLAUTHD "Register dependency for cyrus-sasl2-saslauthd" off
+
+PORTDOCS= AUTHORS LICENSE
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SASLAUTHD)
+RUN_DEPENDS+= saslauthd:${PORTSDIR}/security/cyrus-sasl2-saslauthd
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_authn_sasl/distinfo b/www/mod_authn_sasl/distinfo
new file mode 100644
index 000000000000..4acc6f43c6f9
--- /dev/null
+++ b/www/mod_authn_sasl/distinfo
@@ -0,0 +1,3 @@
+MD5 (mod_authn_sasl-1.0.2.tar.bz2) = 0272cb8550fe557177729b0c927d56f0
+SHA256 (mod_authn_sasl-1.0.2.tar.bz2) = 45f13e976fe93e43ea291528f2de3d97423867c936584265f23a679d7772cea6
+SIZE (mod_authn_sasl-1.0.2.tar.bz2) = 244838
diff --git a/www/mod_authn_sasl/pkg-descr b/www/mod_authn_sasl/pkg-descr
new file mode 100644
index 000000000000..84a3f8da12c4
--- /dev/null
+++ b/www/mod_authn_sasl/pkg-descr
@@ -0,0 +1,6 @@
+This module provides the mod_auth_basic authentication front-end a way to
+authenticate users by checking credentials via the Cyrus SASL library.
+This may be interesting for setups where other daemons (e.g. for SMTP, IMAP or
+LDAP) already running at a machine use SASL to authenticate users.
+
+WWW: http://mod-authn-sasl.sourceforge.net/